Bug 825477 - touchpad events lost after keyboard activity
touchpad events lost after keyboard activity
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 14:42 EDT by Nathan Lynch
Modified: 2012-06-19 09:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 09:43:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (71.35 KB, text/x-log)
2012-05-26 14:42 EDT, Nathan Lynch
no flags Details
dmesg (170.84 KB, text/plain)
2012-05-26 14:44 EDT, Nathan Lynch
no flags Details

  None (edit)
Description Nathan Lynch 2012-05-26 14:42:42 EDT
Created attachment 587026 [details]
Xorg log

Description of problem:
Dell Latitude E6420 (BIOS version 4.6) running Fedora 17

For a period of about two seconds after releasing (almost) any button on the keyboard on this laptop, the touchpad and its buttons act as if disabled.  This happens only in X, not on VGA console (confirmed with gpm).  Shift, Alt, Ctrl, and Windows logo buttons do not trigger this behavior, but everything else does.

The touchpad returns to normal operation about two seconds after the key release.  The touchstick and associated buttons are not affected by this problem, nor is an external USB mouse.


Version-Release number of selected component:

kernel-3.3.5-2.fc16.x86_64
xorg-x11-drv-synaptics-1.6.0-1.fc17.x86_64
xorg-x11-server-Xorg-1.12.0-2.fc17.x86_64


How reproducible:
Consistently reproducible on this system.


Steps to Reproduce:
1. Start xev
2. Position pointer over xev window
3. Press and hold left touchpad button
4. Press and release a key on the keyboard
5. Release touchpad button within 2 seconds

  
Bad results (with "z" key):

ButtonPress event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 402894313, (67,69), root:(69,180),
    state 0x0, button 1, same_screen YES

KeyPress event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 402895965, (67,69), root:(69,180),
    state 0x100, keycode 52 (keysym 0x7a, z), same_screen YES,
    XLookupString gives 1 bytes: (7a) "z"
    XmbLookupString gives 1 bytes: (7a) "z"
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 402896285, (67,69), root:(69,180),
    state 0x100, keycode 52 (keysym 0x7a, z), same_screen YES,
    XLookupString gives 1 bytes: (7a) "z"
    XFilterEvent returns: False

(touchpad button is released but ButtonRelease event never appears)


Good results (with left Shift key):

ButtonPress event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 403170101, (119,75), root:(121,186),
    state 0x0, button 1, same_screen YES

KeyPress event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 403171173, (119,75), root:(121,186),
    state 0x100, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 403171564, (119,75), root:(121,186),
    state 0x101, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

ButtonRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0xbd, subw 0x0, time 403172264, (119,75), root:(121,186),
    state 0x100, button 1, same_screen YES


Additional info:
Have tested this only in Gnome Shell, have not tried other desktop environments.  Have experienced this issue since Fedora 15.
Comment 1 Nathan Lynch 2012-05-26 14:44:04 EDT
Created attachment 587027 [details]
dmesg
Comment 2 Nathan Lynch 2012-05-26 14:50:28 EDT
Maybe this is helpful?  Results of running synclient:

[ntl-latitude-e6420 ~]$ synclient | grep TouchpadOff
    TouchpadOff             = 1
[ntl-latitude-e6420 ~]$ sleep 3 && synclient | grep TouchpadOff
    TouchpadOff             = 0
Comment 3 Nathan Lynch 2012-06-19 09:43:36 EDT
Sigh, PEBKAC.  Fixed by unchecking Settings -> Mouse and Touchpad -> Disable touchpad while typing.  Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.