Bug 82548 - cursor disappears with newest XFree86
Summary: cursor disappears with newest XFree86
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 10:13 UTC by Florian La Roche
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-11 07:53:33 UTC


Attachments (Terms of Use)

Description Florian La Roche 2003-01-23 10:13:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030121

Description of problem:
When XFree86 is changing the cursor, it often disappears completely
for some time.

4.2.99.3-20030115.0 is still ok and
4.2.99.3-20030118.3 and 4.2.99.4-20030121.0 are
both not working.

This is on a Radeon 7500.

greetings,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start on a Dell Latitude
2.
3.
    

Actual Results:  Cursor disappears

Expected Results:  Cursor is always visible.

Additional info:

Greetings to Mike.

Comment 1 Mike A. Harris 2003-01-24 13:33:23 UTC
Does setting the following *before* running startx solve the problem:

export XCURSOR_CORE=yes

Also, after testing that, unset the above variable and then try using
"swcursor" in the config file and restarting.  Does this make the problem
go away?

TIA

Comment 2 Aleksey Nogin 2003-01-25 01:42:54 UTC
I see this as well (Radeon Mobility M7 LW [Radeon Mobility 7500]). Also, when
running virtual size>displayed size, there were large delays with the sreen
scrolling (when the pointer goes past the visible screen boundary).  These made
the whole X experience quite unpleasant...

I've already downgraded back to beta4 X RPMs (besides this bug, the upgrade
broke the unsupported but highly missed synaptics touchpad driver, and I need
the double-tap for button2 even more than I need to see the pointer all the
time). But if I ever have time, I am planning to try the latest X packages from
Rawhide with suggestions in comment #1 (and will try to recompile the synaptics
driver and see if that helps).

Comment 3 Kjartan Maraas 2003-01-26 00:28:29 UTC
Just a datapoint. I see it too with a Radeon Mobility M6 LY

Comment 4 Aleksey Nogin 2003-01-26 06:42:35 UTC
According to http://www.mail-archive.com/xfree86@xfree86.org/msg01051.html,
turning on the swcursor option does work.

<offtopic>
That post also mentions the issue of the machine locking up when the exiting X
under KDM - I see it as well (inlcuding with at least beta3, I believe). Anybody
else seing it? Is it in Bugzilla yet?
</offtopic>

Comment 5 Mike McLean 2003-01-31 23:00:19 UTC
I see this on a Radeon Mobility M7 LW
* XFree86-4.2.99.4-20030129.1

both the XCURSOR_CORE=yes and swcursor directive fix the problem for me.

The cursor disappears for me at a very specific point: when transitioning to and
from the grow-window-right cursor (the one that looks like "->|").  It seems to
just take a long time (~1-2sec) to load or unload this particular cursor.

Comment 6 Aleksey Nogin 2003-02-04 02:00:12 UTC
Still there with the stuff from the latest Rawhide
(XFree86-4.2.99.4-20030129.4). Works OK with swcursor on.

Comment 7 Florian La Roche 2004-06-11 07:53:33 UTC
Closing this, not happening with rawhide anymore...


Note You need to log in before you can comment on or make changes to this bug.