Bug 8255 - Cannot execute ip-up for dialin server
Cannot execute ip-up for dialin server
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-06 22:35 EST by rbiern01
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-19 20:11:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rbiern01 2000-01-06 22:35:26 EST
I'm not sure if this is affecting anything cause I think everything still
appears to work, but I hate seeing errors in the log.

When someone dials in and mgetty correctly starts pppd but I get some
errors in the log saying "ip-up couldnt be started". I also get "ip-down
couldnt be started" when the modem that has dialed in hangs up.

Here is part of the messages file

Jan  7 14:32:05 celcius kernel: CSLIP: code copyright 1989 Regents of the
University of California
Jan  7 14:32:05 celcius kernel: PPP: version 2.3.3 (demand dialling)
Jan  7 14:32:05 celcius kernel: PPP line discipline registered.
Jan  7 14:32:05 celcius kernel: registered device ppp0
Jan  7 14:32:06 celcius kernel: ppp_ioctl: set dbg flags to 70000
Jan  7 14:32:06 celcius kernel: ppp_ioctl: set flags to 70000
Jan  7 14:32:06 celcius kernel: ppp_tty_ioctl: set xasyncmap
Jan  7 14:32:06 celcius kernel: ppp_tty_ioctl: set xmit asyncmap ffffffff
Jan  7 14:32:06 celcius kernel: ppp_ioctl: set flags to 70000
Jan  7 14:32:06 celcius kernel: ppp_ioctl: set mru to 5dc
Jan  7 14:32:06 celcius kernel: ppp_tty_ioctl: set rcv asyncmap ffffffff
Jan  7 14:32:05 celcius pppd[2231]: pppd 2.3.7 started by a_ppp, uid 0
Jan  7 14:32:05 celcius pppd[2231]: Removed stale lock on ttyS1 (pid 2231)
Jan  7 14:32:06 celcius pppd[2231]: Using interface ppp0
Jan  7 14:32:06 celcius pppd[2231]: Connect: ppp0 <--> /dev/ttyS1
Jan  7 14:32:06 celcius kernel: ppp_ioctl: set flags to 70000
Jan  7 14:32:09 celcius kernel: ppp_tty_ioctl: set xmit asyncmap 0
Jan  7 14:32:09 celcius kernel: ppp_ioctl: set flags to f070003
Jan  7 14:32:09 celcius kernel: ppp_ioctl: set mru to 5dc
Jan  7 14:32:09 celcius kernel: ppp_tty_ioctl: set rcv asyncmap 0
Jan  7 14:32:09 celcius kernel: ppp_ioctl: set flags to f070003
Jan  7 14:32:09 celcius kernel: ppp_ioctl: set flags to f070043
Jan  7 14:32:09 celcius kernel: PPP BSD Compression module registered
Jan  7 14:32:09 celcius kernel: PPP Deflate Compression module registered
Jan  7 14:32:09 celcius pppd[2231]: CHAP peer authentication succeeded for
**************
Jan  7 14:32:12 celcius kernel: ppp_ioctl: set flags to f070003
Jan  7 14:32:14 celcius kernel: ppp_ioctl: set maxcid to 12
Jan  7 14:32:14 celcius kernel: ppp_ioctl: set flags to f070007
Jan  7 14:32:14 celcius pppd[2231]: found interface eth0 for proxy arp
Jan  7 14:32:14 celcius pppd[2231]: local  IP address 172.22.250.9
Jan  7 14:32:14 celcius pppd[2231]: remote IP address 172.22.250.40
Jan  7 14:32:14 celcius pppd[2231]: Can't execute /etc/ppp/ip-up: Invalid
argument
Jan  7 14:32:15 celcius kernel: ppp_ioctl: set flags to f07000b
Jan  7 14:32:15 celcius pppd[2231]: Can't execute /etc/ppp/ip-down: Invalid
argument
Jan  7 14:32:19 celcius kernel: ppp_ioctl: set maxcid to 12
Jan  7 14:32:19 celcius kernel: ppp_ioctl: set flags to f070007
Jan  7 14:32:19 celcius pppd[2231]: found interface eth0 for proxy arp
Jan  7 14:32:19 celcius pppd[2231]: local  IP address 172.22.250.9
Jan  7 14:32:19 celcius pppd[2231]: remote IP address 172.22.250.40
Jan  7 14:32:19 celcius pppd[2231]: Can't execute /etc/ppp/ip-up: Invalid
argument
Jan  7 14:32:41 celcius kernel: 20 20 20 20 20 20 20

I am not sure wether this is normal or not but since I'm still in testing
and have the kdebug turned up pretty high I get quite a bit of stuff in the
log.

Here is one of my options.ttySx files that contain all the options pppd is
started with except kdebug

-detach
ttyS0 57600 crtscts
auth
debug
bsdcomp 12
deflate 12
vj-max-slots 12
require-chap
nodefaultroute
lock
:172.22.250.39
proxyarp
idle 900
ms-dns 172.22.250.10
ms-dns 172.22.250.11

Thanks
Comment 1 Nalin Dahyabhai 2000-01-17 12:29:59 EST
Please upgrade to the newest ppp and initscripts packages, and let me know
if this continues to be a problem.
http://www.redhat.com/support/errata/RHSA1999052-04.html
http://www.redhat.com/support/errata/RHEA1999051-01.html
Comment 2 rbiern01 2000-01-17 20:25:59 EST
I downloaded the new update to the init scripts but it is for people running
RedHat 6.1 not 6.0 and I get dependecy errors when I try and install it. I PPP
though and I still get the error though.
Comment 3 Nalin Dahyabhai 2000-01-19 10:11:59 EST
From my reading of the pppd(8) man page, it looks like the -detach
flag is invalid because it is the default.
Comment 4 Nalin Dahyabhai 2000-01-19 20:11:59 EST
My mistake.  The -detach option is apparently fine, as we add it in our init
scripts.  The call to syslog() with the error you're seeing happens after a
failed execve() call, where according to its man page the error indicates:
       EINVAL  An ELF executable had more than one PT_INTERP seg-
               ment (i.e., tried to name  more  than  one  inter-
               preter).

Do the ip-up and ip-down scripts exist?  If so, have they been modified from
the defaults included in the initscripts package?
Comment 5 Brent Fox 2002-06-05 11:52:26 EDT
Closing due to old age.

Note You need to log in before you can comment on or make changes to this bug.