Bug 825546 - SELinux is preventing qemu-system-x86 from 'write' accesses on the file /home/dag/.libvirt/qemu/log/nixos-minimal-0.1pre34218-34232-i686-linux.iso.log.
SELinux is preventing qemu-system-x86 from 'write' accesses on the file /home...
Status: CLOSED DUPLICATE of bug 809910
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9c3272d062b3c2415d0464b9ffd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 13:26 EDT by Dag Odenhall
Modified: 2012-05-28 04:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 04:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Odenhall 2012-05-27 13:26:13 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.i686
time:           Sun 27 May 2012 07:25:30 PM CEST

description:
:SELinux is preventing qemu-system-x86 from 'write' accesses on the file /home/dag/.libvirt/qemu/log/nixos-minimal-0.1pre34218-34232-i686-linux.iso.log.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that qemu-system-x86 should be allowed write access on the nixos-minimal-0.1pre34218-34232-i686-linux.iso.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-system-x86 /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:svirt_t:s0:c262,c646
:Target Context                unconfined_u:object_r:virt_home_t:s0
:Target Objects                /home/dag/.libvirt/qemu/log/nixos-
:                              minimal-0.1pre34218-34232-i686-linux.iso.log [
:                              file ]
:Source                        qemu-system-x86
:Source Path                   qemu-system-x86
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.i686 #1 SMP Mon May 21
:                              22:50:24 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sun 27 May 2012 07:24:07 PM CEST
:Last Seen                     Sun 27 May 2012 07:24:07 PM CEST
:Local ID                      04dd0156-a1c6-4b5c-a770-3f68e028ea9e
:
:Raw Audit Messages
:type=AVC msg=audit(1338139447.843:552): avc:  denied  { write } for  pid=32087 comm="qemu-system-x86" path="/home/dag/.libvirt/qemu/log/nixos-minimal-0.1pre34218-34232-i686-linux.iso.log" dev="sda1" ino=265901 scontext=system_u:system_r:svirt_t:s0:c262,c646 tcontext=unconfined_u:object_r:virt_home_t:s0 tclass=file
:
:
:Hash: qemu-system-x86,svirt_t,virt_home_t,file,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Dag Odenhall 2012-05-27 13:33:56 EDT
More generally, gnome-boxes fails to create boxes from images with the error message "Box creation failed!" at which point a SELinux alert like this one pops up.
Comment 2 Miroslav Grepl 2012-05-28 04:57:04 EDT

*** This bug has been marked as a duplicate of bug 809910 ***

Note You need to log in before you can comment on or make changes to this bug.