This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 825548 - [abrt] libreoffice-core-3.5.3.2-3.fc17 specific rtf document incredibly slow to load
[abrt] libreoffice-core-3.5.3.2-3.fc17 specific rtf document incredibly slow ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:acd97f13e0d77b207a51196f7f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 13:31 EDT by Mikhail
Modified: 2012-05-30 08:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 08:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (69.46 KB, text/plain)
2012-05-27 13:31 EDT, Mikhail
no flags Details
File: maps (50.66 KB, text/plain)
2012-05-27 13:31 EDT, Mikhail
no flags Details
File: dso_list (16.65 KB, text/plain)
2012-05-27 13:31 EDT, Mikhail
no flags Details
File: build_ids (6.77 KB, text/plain)
2012-05-27 13:31 EDT, Mikhail
no flags Details
problem doc file (784.74 KB, application/octet-stream)
2012-05-28 13:36 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 49968 None None None Never

  None (edit)
Description Mikhail 2012-05-27 13:31:09 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer file:///home/mikhail/Downloads/4f6b72f99e1d97_58243324.doc --splash-pipe=6
comment:        libreoffice hang's when I open document then I kill him
crash_function: _int_free
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.3.7-1.fc17.i686.PAE
pid:            11245
pwd:            /home/mikhail
time:           Сб. 26 мая 2012 19:47:41
uid:            1000
username:       mikhail
var_log_messages: May 26 19:47:41 p5k abrt[18799]: Saved core dump of pid 11245 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-05-26-19:47:41-11245 (84938752 bytes)
xsession_errors: 

backtrace:      Text file, 71124 bytes
build_ids:      Text file, 6929 bytes
dso_list:       Text file, 17052 bytes
maps:           Text file, 51877 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mikhail/2

core_backtrace:
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x73b53 _int_free libc.so.6 -
:757d0ed5f496fc377d8558caf8987cefa4679f96 0x4b960 operator libstdc++.so.6 -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x3b59e - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x39f38 - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x39fa3 - librtftoklo.so -
:b85e002e9b0da0eb8acd15c25186f35b69e73744 0x63bfd - libooxmllo.so -
:b85e002e9b0da0eb8acd15c25186f35b69e73744 0x3c4e1 writerfilter::dmapper::DomainMapper::lcl_sprm(writerfilter::Sprm&) libooxmllo.so -
:ad4d1adb7bec0ac3c99a89a4c44603b7a54d6c0a 0x8908 writerfilter::LoggedProperties::sprm(writerfilter::Sprm&) libresourcemodello.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x392a5 - librtftoklo.so -
:b85e002e9b0da0eb8acd15c25186f35b69e73744 0x2e1dc writerfilter::dmapper::DomainMapper::lcl_props(boost::shared_ptr<writerfilter::Reference<writerfilter::Properties> libooxmllo.so -
:ad4d1adb7bec0ac3c99a89a4c44603b7a54d6c0a 0x8bba writerfilter::LoggedStream::props(boost::shared_ptr<writerfilter::Reference<writerfilter::Properties> libresourcemodello.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x14279 - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x14ac3 - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x14b9c - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x3876f - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x38a03 - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x38eba - librtftoklo.so -
:a40101f6a4a410637b326ac3937034a1a34c4980 0x8187 - librtftoklo.so -
:4a7c7ad988604189b02767d7fd5336a61faf526f 0x85a9 RtfFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libwriterfilterlo.so -
:923e2d45d942b0f88d871367a37a13bd44a8a0f3 0x284a43 SfxObjectShell::ImportFrom(SfxMedium&, libsfxlo.so -
:923e2d45d942b0f88d871367a37a13bd44a8a0f3 0x289cbd SfxObjectShell::DoLoad(SfxMedium*) libsfxlo.so -
:923e2d45d942b0f88d871367a37a13bd44a8a0f3 0x2ca324 SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libsfxlo.so -
:923e2d45d942b0f88d871367a37a13bd44a8a0f3 0x303480 - libsfxlo.so -
:41c725e9dad99fe7417d53bfaa05cbcaa4b7ca94 0xeafd8 - libfwklo.so -
:41c725e9dad99fe7417d53bfaa05cbcaa4b7ca94 0xec378 - libfwklo.so -
:41c725e9dad99fe7417d53bfaa05cbcaa4b7ca94 0x7b4c8 - libfwklo.so -
:41c725e9dad99fe7417d53bfaa05cbcaa4b7ca94 0x7bab5 - libfwklo.so -
:- 0x0 - - -

environ:
:XDG_VTNR=1
:INSIDE_NAUTILUS_PYTHON=
:XDG_SESSION_ID=2
:HOSTNAME=p5k
:LC_MONETARY=ru_RU.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:NAUTILUS_PYTHON_REQUIRE_GTK3=1
:GIO_LAUNCHED_DESKTOP_FILE_PID=11225
:GPG_AGENT_INFO=/run/user/mikhail/keyring-ODWcUJ/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-1537-p5k-libreoffice-34_TIME28529258
:HISTSIZE=1000
:XDG_SESSION_COOKIE=02dd4a7644acf695092726df00000077-1338010960.396942-289811657
:LC_NUMERIC=ru_RU.utf8
:OLDPWD=/usr/lib/libreoffice/program
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/mikhail/keyring-ODWcUJ
:QTINC=/usr/lib/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=mikhail
:SSH_AUTH_SOCK=/run/user/mikhail/keyring-ODWcUJ/ssh
:USERNAME=mikhail
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1298,unix/unix:/tmp/.ICE-unix/1298
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1296
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:LC_MEASUREMENT=ru_RU.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=mikhail
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-hnEEtaUBlK,guid=4e1aec7eb74b727e1d7b763e00000013
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0.0
:LC_TIME=ru_RU.utf8
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-rQYhj7/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 32168                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       32168                32168                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mikhail/.xsession-errors
:pos:	386998
:flags:	02002
:2:/home/mikhail/.xsession-errors
:pos:	386998
:flags:	02002
:3:socket:[9246465]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[9247780]
:pos:	0
:flags:	00
:6:pipe:[9247780]
:pos:	0
:flags:	01
:7:socket:[9247494]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: 19815844-d1b0-4560-89c6-5f679132ab98
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 4811.22
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 4
:CPU Speed: 2394
:System Memory: 4037
:System Swap: 4095
:Vendor: System manufacturer
:System: P5K System Version
:Form factor: Desktop
:Kernel: 3.3.7-1.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10688:4163:33398) pci, None, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10689:4163:33398) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(32902:10544:4163:33399) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10529:4163:33399) pci, ata_piix, STORAGE, 82801IB (ICH9) 2 port SATA IDE Controller
:(32902:10520:4163:33399) pci, None, PCI/ISA, 82801IB (ICH9) LPC Interface Controller
:(32902:10534:4163:33399) pci, ata_piix, STORAGE, 82801I (ICH9 Family) 2 port SATA IDE Controller
:(6505:4168:4163:33318) pci, atl1, ETHERNET, P5KPL-VM Motherboard
:(32902:10549:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9294:4163:33399) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10553:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4163:33399) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4163:33399) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(6523:9059:4163:33359) pci, pata_jmicron, STORAGE, JMB362/JMB363 Serial ATA Controller
:(6523:9059:4163:33359) pci, ahci, STORAGE, JMB362/JMB363 Serial ATA Controller
:(32902:10560:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10570:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(32902:10551:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10548:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(4318:1553:6618:4160) pci, nouveau, VIDEO, ZT-88TES2P-FSP
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(5138:5924:12337:17747) pci, snd_ice1724, MULTIMEDIA_AUDIO, VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
:(32902:10552:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 7314791 4251983 4178754 1835008 1497065 1497065
:/dev/sdb1 /home ext4 4096 4096 365928275 219372925 201058725 91578368 91347044 91347044
:/dev/sdc1 WITHHELD ext2 UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN
:
Comment 1 Mikhail 2012-05-27 13:31:15 EDT
Created attachment 587098 [details]
File: backtrace
Comment 2 Mikhail 2012-05-27 13:31:17 EDT
Created attachment 587099 [details]
File: maps
Comment 3 Mikhail 2012-05-27 13:31:20 EDT
Created attachment 587100 [details]
File: dso_list
Comment 4 Mikhail 2012-05-27 13:31:22 EDT
Created attachment 587101 [details]
File: build_ids
Comment 5 David Tardon 2012-05-28 06:26:25 EDT
could you attach the rtf file here?
Comment 6 Mikhail 2012-05-28 13:36:05 EDT
Created attachment 587271 [details]
problem doc file
Comment 7 Caolan McNamara 2012-05-29 16:36:32 EDT
In master I don't get it to crash, but it is *incredibly* slow and its hot spot is exactly that of the backtrace. I could well believe that its eating insane amounts of memory.

caolanm->dtardon: are your recent changes upstream with RTFValue related to this bug ?
Comment 8 Mikhail 2012-05-29 22:13:00 EDT
This crash occurs when I do "kill -9" to hang libreoffice process.
Comment 9 David Tardon 2012-05-30 00:22:25 EDT
dtardon->caolanm: Sort of. I looked around the related code a bit and the missing operator= seemed a potential problem. But I have no idea if it fixes this bug or not.
Comment 10 Caolan McNamara 2012-05-30 05:54:16 EDT
ah, manual kill during the load, That makes sense because its so incredibly slow to load, rather a vital piece of information :-)
Comment 11 Caolan McNamara 2012-05-30 08:36:22 EDT
Indeed staggeringly slow to load, there are very few /pard tags to reset attributes to defaults and the same attributes appear again and again so the list of properties grows to insane levels, although they are just the same properties again and again.

I've implement an optimization to avoid the properties growing hugely if we can determine that they can be merged at load time.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=651d045cddf8fd238999cb3442e87410f1a8e1df

This will appear in LibreOffice 3.6. I'll run it past vmiklos to see if he reckons its safe for a 3.5.X

Note You need to log in before you can comment on or make changes to this bug.