Bug 825569 - [enhancement]: Add support for noatime, nodiratime
[enhancement]: Add support for noatime, nodiratime
Status: CLOSED EOL
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 17:37 EDT by Joe Julian
Modified: 2016-04-07 19:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 11:46:38 EDT
Type: Bug
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-05-27 17:37:43 EDT
Attempting to mount the volume with noatime and/or nodiratime results in the message, "unknown option no[dir]atime" and the volume is mounted without it.

Updating atime without need is a known performance issue on high volume servers.
Comment 1 Kaushal 2012-05-28 08:34:21 EDT
Are you sure this could be done earlier?

I tested with 3.1, 3.2 and 3.3 (latest git branches). All of them don't support noatime. The mount.glusterfs script in 3.1 and 3.2 just dropped the unknown options passed with -o silently. The mount script was reworked in 3.3, so that it makes some noise about unknown options.

In 3.3, I also tried forcibly adding a "noatime" option by adding it to the mnt_args string in the source code. (fuse-bridge.c, the init() function). This lead to mount failures with a normal build. Looks like the fuse-lib used by gluster doesn't support "noatime" as an option. I tried a build with fusermount enabled (using --enable-fusermount with the configure script). It was only with this that mount succeeded. Then tried forcibly adding a "nodiratime" option. This option caused both normal and fusermount mounts to fail.

So it looks like gluster never supported these two options out of the box!

Regards,
Kaushal
Comment 2 Joe Julian 2012-05-28 12:25:37 EDT
Although I've had that in my mount options forever, no. I don't know that it was working.

I've changed this to an enhancement request.
Comment 3 Andrew Hatfield 2013-01-29 23:10:11 EST
For those Volumes where you want noatime and nodiratime, why not set those mount options on the Bricks?
Comment 4 Amar Tumballi 2013-02-20 01:15:35 EST
for now, the best option is what Andrew (comment #3) suggested. will keep this open for some time to see if there is a possibility in glusterfs to not to bother about time.
Comment 5 Colin Alston 2014-05-29 11:43:11 EDT
*bump* The fun part of this issue is that if you do set nodiratime, glusterfs 3.4 mounts just break with no clear error. More confusingly, the trace error you do end up with is

[2014-05-29 04:58:33.129366] E [mount.c:162:fuse_mount_fusermount] 0-glusterfs-fuse: failed to exec fusermount: No such file or directory

Wat.
Comment 6 Kaleb KEITHLEY 2015-10-22 11:46:38 EDT
because of the large number of bugs filed against mainline version\ is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.

Note You need to log in before you can comment on or make changes to this bug.