Bug 825602 - Cannot register authentication agent! (prelink related)
Cannot register authentication agent! (prelink related)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: polkit-kde (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 23:43 EDT by Sergio Monteiro Basto
Modified: 2012-05-30 13:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 19:03:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Monteiro Basto 2012-05-27 23:43:11 EDT
Description of problem:
after upgrade to F17 , I got several "not authorized" 


see for example bug 820675 

I  notice when I run polkit-kde-authentication-agent-1, I got  assertion Failed

/usr/libexec/kde4/polkit-kde-authentication-agent-1
New PolkitAgentListener  0x225bac0 
Adding new listener  PolkitQt1::Agent::Listener(0x23d0b50) for  0x225bac0 
"Cannot create unix session: No session for pid 8986" 

** (process:8986): CRITICAL **: polkit_agent_listener_register: assertion `POLKIT_IS_SUBJECT (subject)' failed
"Cannot register authentication agent!" 

(process:8986): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

How I fix this ?
Comment 1 David Zeuthen 2012-05-29 10:28:43 EDT
polkit works just fine, seems like it's a problem with KDE's usage of it, reassigning
Comment 2 Rex Dieter 2012-05-29 10:31:51 EDT
rpm -q polkit-qt polkit-kde

please.

While we're at it, may be worth doing:

yum distro-sync

to make sure you've got the right versions of all packages installed (in case something got missed during the upgrade)
Comment 3 Sergio Monteiro Basto 2012-05-29 13:56:31 EDT
hi , I will provide detailed information at end of the night (2300 UTC) , this happens on my home desktop. 

but I think I had done yum distro-sync and use 
rpmconf to clean up rpmnew and rpmsaves, and I think this begins to happens just after rpmconf cleanup !
Comment 4 Sergio Monteiro Basto 2012-05-29 18:53:57 EDT
Hi, I already fixed it. but could happen to someone else.

rpm -q polkit-qt polkit-kde
polkit-qt-0.103.0-2.fc17.x86_64
polkit-kde-0.99.0-4.fc17.x86_64

but: rpm -q polkit-qt polkit-kde -V
I got several 
prelink: (...).so: at least one of file's dependencies has changed since prelinking

I remember that I had already run /etc/cron.daily/prelink 

so I do 
yum reinstall polkit-qt-0.103.0-2.fc17.x86_64 polkit-kde-0.99.0-4.fc17.x86_64

and after reboot (important) every thing works fine. 
and rpm -q polkit-qt polkit-kde -V gives a clean result.
Comment 5 Rex Dieter 2012-05-29 19:03:01 EDT
that's odd, so basically some prelink wierdness going on, fun.
Comment 6 Kevin Kofler 2012-05-30 10:10:26 EDT
Are you using the proprietary NVidia driver? If so, it's probably a duplicate of bug #751891.
Comment 7 Sergio Monteiro Basto 2012-05-30 13:16:13 EDT
(In reply to comment #6)
> Are you using the proprietary NVidia driver? If so, it's probably a
> duplicate of bug #751891.

I use the proprietary NVidia driver, on that machine ,
but prelink warnings was in rpm -V polkit-qt polkit-kde 

but don't see any relation,  I just got a simple message that can't register authentication agent , and apper pop ups a dialog saying that I am not authorized. 

any way see if I have problems with prelink ?

Note You need to log in before you can comment on or make changes to this bug.