Bug 825735 - RFE: Provide tui screen to set partition sizes
RFE: Provide tui screen to set partition sizes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: FutureFeature
Depends On: 848649
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 06:12 EDT by Guohua Ouyang
Modified: 2016-04-26 09:25 EDT (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Enhancement
Doc Text:
There is now a TUI screen to set partition sizes when configuring the hypervisor.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:34:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (51.48 KB, image/png)
2012-05-28 06:12 EDT, Guohua Ouyang
no flags Details

  None (edit)
Description Guohua Ouyang 2012-05-28 06:12:48 EDT
Created attachment 587201 [details]
screenshot

Description of problem:
on a big memory machine, during install will report "not enough space for installation". It should be the swap_size is too big.

The current method to allocate the swap_size is:
SWAP_SIZE =  int(BASE_SWAP_SIZE) + int(OVERCOMMIT_SWAP_SIZE)
1. BASE_SWAP_SIZE:
if MEM_SIZE_GB < 4:
            BASE_SWAP_SIZE=2048
        elif MEM_SIZE_GB < 16:
            BASE_SWAP_SIZE=4096
        elif MEM_SIZE_GB < 64:
            BASE_SWAP_SIZE=8192
        else:
            BASE_SWAP_SIZE=16384
2. OVERCOMMIT_SWAP_SIZE:
OVERCOMMIT_SWAP_SIZE = int(MEM_SIZE_MB) * self.overcommit * 10 / 10
overcommit=0.5

On a machine with 256 GB mem, the SWAP_SIZE will large than 100GB.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6

How reproducible:
100%

Steps to Reproduce:
1. tui install rhevh on a big memory machine, such as have 256GB mem.

Actual results:
during install will report "not enough space for installation".

Expected results:
install can continue.
Comment 2 Mike Burns 2012-05-29 08:09:48 EDT
This is really NOTABUG, but I'll defer it to 6.4 as an RFE to add a partition size configuration screen.  

In the above case, if you provide a disk large enough, the installation will be successful.  If you want to customize the swap size, you can specify it in the storage_vol kernel command line parameter.
Comment 3 Mike Burns 2012-06-12 13:44:01 EDT
another option is to allow the user to set the overcommit value (which defaults to 0.5).
Comment 5 RHEL Product and Program Management 2012-07-10 02:33:41 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:49:58 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Mike Burns 2012-10-12 16:48:25 EDT
upstream patch:  http://gerrit.ovirt.org/#/c/8520/



                                                                                
    oVirt Node Hypervisor 2.5.999-999.201210101948.fc17                         
                                                                                
┌─────────────────────────────┤  ├─────────────────────────────┐                
│                                                              │                
│                                                              │                
│ Please enter the sizes for the following partitions in MB    │                
│                                                              │                
│ UEFI/Bios:         256_______                                │                
│ Root & RootBackup: 256_______  (2 partitions at 256MB each)  │                
│ Swap:              39________                                │                
│ Config:            500_______                                │                
│ Logging:           2048______                                │                
│ Data:              100_______                                │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│                                                              │                
│   <Quit>   <Back>   <Continue>                               │
Comment 11 errata-xmlrpc 2013-02-28 11:34:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.