Bug 825749 - perl-5.16.0: XS::APItest accesses memory after free()
perl-5.16.0: XS::APItest accesses memory after free()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://rt.perl.org/rt3//Public/Bug/D...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 07:16 EDT by Petr Pisar
Modified: 2012-09-20 16:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: perl-5.16.1-233.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-05-28 07:16:52 EDT
Upstream 5.16.0 perl release has a bug in XS::APItest. The problem is in accessing unallocated memory. Reported to upstream mailing list with proposed patch (http://thread.gmane.org/gmane.comp.lang.perl.perl5.porters/109408).

We need to fix it after bumping 5.16.0 into Fedora.
Comment 1 Petr Pisar 2012-09-11 03:07:11 EDT
This proposed fix has been merged into upstream as commit:

commit 4a808ed163df1057031bc6d085300fe1ef6f57d2
Author: Michael Schroeder <mls@suse.de>
Date:   Fri Jun 8 20:29:54 2012 -0700

    [perl #111610] Trouble with XS-APItest/t/clone-with-stack.t
Comment 2 Fedora Update System 2012-09-11 09:26:11 EDT
perl-5.16.1-230.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-5.16.1-230.fc18
Comment 3 Fedora Update System 2012-09-11 15:12:13 EDT
Package perl-5.16.1-230.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-5.16.1-230.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13814/perl-5.16.1-230.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-09-14 08:03:54 EDT
perl-5.16.1-231.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-5.16.1-231.fc18
Comment 5 Fedora Update System 2012-09-20 16:38:42 EDT
perl-5.16.1-231.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.