Bug 825764 - Ticket Monster transitively depends on com.google.inject:guice:jar:3.0-redhat-1 that can't be found
Ticket Monster transitively depends on com.google.inject:guice:jar:3.0-redhat...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai (Show other bugs)
2.0.0.ER6
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0.0.ER8
Assigned To: Pavel SLegr
Tomas Repel
ticket-monster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 08:20 EDT by Tomas Repel
Modified: 2012-06-22 03:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2012-05-28 08:20:18 EDT
Description of problem:

Ticket Monster example depends on errai-bus:2.0.0.Final-redhat-1 that depends on guice:3.0-redhat-1. However, this (guice) dependency is not neither in EAP6 ER8 maven repository nor in WFK2 ER6 maven repository. 

Version-Release number of selected component (if applicable):

WFK2 ER6
EAP6 ER8

How reproducible:

Always.

Steps to Reproduce:
1. package Ticket Monster example
  
Actual results:

[ERROR] Failed to execute goal on project ticket-monster: Could not resolve dependencies for project org.jboss.jdf.examples:ticket-monster:war:1.0-redhat-1: The following artifacts could not be resolved: com.google.inject:guice:jar:3.0-redhat-1, hsqldb:hsqldb:jar:1.8.0.10-patch-01, org.jboss.weld:weld-build-config:jar:1.1.8.Final-redhat-1: Failure to find com.google.inject:guice:jar:3.0-redhat-1 in file:///home/trepel/sources/wfk-qa/build/configuration/../../../obsolete-repository was cached in the local repository, resolution will not be reattempted until the update interval of obsolete-enterprise-repository has elapsed or updates are forced -> [Help 1]

Expected results:

It creates ticket-monster.war
Comment 1 Tomas Repel 2012-05-28 08:33:55 EDT
Ticket monster example transitively depends on another two missing dependencies: 

 - hsqldb:hsqldb:jar:1.8.0.10-patch-01 (because of errai-tools:2.0.0.Final-redhat-1 dependency)

 - org.jboss.weld:weld-build-config:jar:1.1.8.Final-redhat-1 (because of errai-weld-integration:2.0.0.Final-redhat-1)
Comment 2 Pavel SLegr 2012-06-06 03:26:24 EDT
fixed in wfk-prod-2.0.1.Final , changed back into version, that can be found in maven central: guice-3.0, hsqldb-1.8.0.7, guava-12.0, resteasy-2.2.3.GA and removed weld-build-config dependency as this one is only checkstyle definition
Comment 3 Pavel SLegr 2012-06-06 06:50:52 EDT
Tried now to build localy TM with already cleaned dependecies (with wfk-prod-2.0.1.Final HEAD) and with localy set up jboss-eap-6.0.0.CR1-maven-repository & jboss-wfk-2.0.0.ER7-maven-repository M2 repos... built success...
Comment 4 Tomas Repel 2012-06-13 05:57:57 EDT
Verified in WFK2 ER8.

Note You need to log in before you can comment on or make changes to this bug.