Bug 825808 - Cannot umount NFS mount containing no leader / on path
Cannot umount NFS mount containing no leader / on path
Status: CLOSED DUPLICATE of bug 758000
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 10:08 EDT by Simon Thompson
Modified: 2012-05-29 11:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 11:24:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Thompson 2012-05-28 10:08:33 EDT
Description of problem:
When mounting an NFSv4 share off an OpenIndiana NFS server with ZFS, unable to unmount the file-system without needing to edit /etc/mtab file

Version-Release number of selected component (if applicable):
Technically, this is on SL 6.2:

cat /etc/redhat-release 
Scientific Linux release 6.2 (Carbon)

rpm -q nfs-utils
nfs-utils-1.2.3-15.el6.0.sl6.x86_64

Steps to Reproduce:
1.  mount fileserver:tank/research
2.  mount | grep mnt
fileserver:tank/research on /mnt type nfs (rw,vers=4,addr=147.188.x.x,clientaddr=147.188.x.x)

 
Actual results:
umount /mnt
/mnt was not found in /proc/mounts
/mnt was not found in /proc/mounts

grep mnt /proc/mounts
fileserver:/tank/research/ /mnt nfs4 rw,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=147.188.x.x,minorversion=0,local_lock=none,addr=147.188.x.x 0 0

Expected results:
Should be able to unmount file system.

Additional info:
Possibly related to #802048 ? - Problem arises because its not mounted with leading / on mount point. Editing /etc/mtab file and adding in a leading / allows file-system to be unmounted as expected.
Comment 2 Steve Dickson 2012-05-29 11:24:41 EDT

*** This bug has been marked as a duplicate of bug 758000 ***

Note You need to log in before you can comment on or make changes to this bug.