Bug 825813 - FTBFS with doxygen 1.8.0+
FTBFS with doxygen 1.8.0+
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libnl3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17FTBFS
  Show dependency treegraph
 
Reported: 2012-05-28 10:22 EDT by Dan Horák
Modified: 2013-02-20 09:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 09:21:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2012-05-28 10:22:06 EDT
Build of libnl3 now fails with
(/usr/share/texmf/tex/latex/graphics/keyval.sty)
(/usr/share/texmf/tex/latex/graphics/graphics.sty
(/usr/share/texmf/tex/latex/graphics/trig.sty)
(/usr/share/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf/tex/latex/graphics/dvips.def))))
No file _formulas.aux.
[1] [2] [3] [4] (./_formulas.aux) )
Output written on _formulas.dvi (4 pages, 1060 bytes).
Transcript written on _formulas.log.
./gen-tags.sh | ./tags2dict.sh > libnl.dict
make[1]: Leaving directory `/builddir/build/BUILD/libnl-3.2.7/doc'
make[1]: *** [api_ref] Error 1
make: *** [gendoc] Error 2
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.QYofyB (%build)
    Bad exit status from /var/tmp/rpm-tmp.QYofyB (%build)
Child returncode was: 1

The reason is that the documentation generation scripts depend on doxytag function, but it was removed in doxygen 1.8.0. It also means that both F-17 and Rawhide are affected.

Version-Release number of selected component (if applicable):
libnl3-3.2.7-1.fc18
Comment 2 Mat Booth 2013-02-20 09:21:03 EST
Looks like this package is now building for all branches: http://koji.fedoraproject.org/koji/packageinfo?packageID=13149

Note You need to log in before you can comment on or make changes to this bug.