Bug 825845 - GTX warnings displayed when yumex is started in a terminal
GTX warnings displayed when yumex is started in a terminal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
16
i586 Linux
unspecified Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 13:28 EDT by Peter Trenholme
Modified: 2012-08-24 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 22:57:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2012-05-28 13:28:42 EDT
Description of problem: I started yumex from a terminal (Using "yumed --root" because the login pop-up kept rejecting the root password, but that's a different issue.) and noticed that GTX had issued 2 warnings:

(yumex:22877): Gtk-WARNING **: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead

(yumex:22877): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 57: Odd character 'd', expected a '=' after attribute name 'rebuilding' of element 'locally'



Version-Release number of selected component (if applicable): 3.0.5-2.fc16


How reproducible: Every time


Steps to Reproduce:
1. start yumex from a terminal window
2.
3.
  
Actual results:
Occasional GTX warning displayed

Expected results:
No warnings should be generated

Additional info:
These are both minor warnings (and the second one is probably a typo), but that's no reason to not fix them in the next release.
Comment 1 Tim Lauridsen 2012-05-31 10:28:05 EDT
The yumex gui is made using glade-3, there must be some issues in the generated xml file, the warnings happens when the .glade file is loaded into gtk.

Without knowing gtk internals, it is hard to find and fix the issue
Comment 2 Tim Lauridsen 2012-06-09 08:43:22 EDT
This one is fixed upstream

(yumex:22877): Gtk-WARNING **: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead

https://github.com/timlau/yumex/commit/a655d32a8270c07c36e1291909e47c24651e5870

Can't reproduce this one in current upstream on Fedora 17.

(yumex:22877): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 57: Odd character 'd', expected a '=' after attribute name 'rebuilding' of element 'locally'
Comment 3 Fedora Update System 2012-08-08 04:41:57 EDT
yumex-3.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc16
Comment 4 Fedora Update System 2012-08-08 04:42:30 EDT
yumex-3.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc17
Comment 5 Fedora Update System 2012-08-09 18:50:45 EDT
Package yumex-3.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11560/yumex-3.0.6-1.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-08-24 22:57:28 EDT
yumex-3.0.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-08-24 23:00:11 EDT
yumex-3.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.