Bug 825851 - grub2 installed from F17 RC3 displaying a 'blackish' no theme after commenting GRUB_THEME
grub2 installed from F17 RC3 displaying a 'blackish' no theme after commentin...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 13:52 EDT by Pratyush Sahay
Modified: 2012-05-29 05:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 05:04:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contents of /etc/grub2.cfg (7.70 KB, application/octet-stream)
2012-05-28 13:52 EDT, Pratyush Sahay
no flags Details
/etc/default/grub contents (220 bytes, text/plain)
2012-05-28 13:53 EDT, Pratyush Sahay
no flags Details
image of the grub2 menu that shows up (387.03 KB, image/jpeg)
2012-05-28 13:55 EDT, Pratyush Sahay
no flags Details
grub2 menu from RC4 install (360.15 KB, image/jpeg)
2012-05-28 22:41 EDT, Pratyush Sahay
no flags Details

  None (edit)
Description Pratyush Sahay 2012-05-28 13:52:11 EDT
Created attachment 587274 [details]
contents of /etc/grub2.cfg

Description of problem: After commenting out GRUB_THEME in /etc/default/grub to remove the fancy grub theme and running grub2-mkconfig in F17 installed from RC3, grub menu shows up in a 'blackish' no theme style, much different from the 'grayish' theme present by default in F17 RC4 installs.


Version-Release number of selected component (if applicable):
grub2-2.0-0.25.beta4.fc17.x86_64


How reproducible: Always (tried on a virtual system, as well as normal install)


Steps to Reproduce:
1. comment out GRUB_THEME in /etc/default/grub
2. run: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
3. reboot system and check the grub menu
  
Actual results: 


Expected results: grub2 menu with the 'grayish' theme similar to the one in installs from F17 RC4.


Additional info:
Comment 1 Pratyush Sahay 2012-05-28 13:53:40 EDT
Created attachment 587275 [details]
/etc/default/grub contents
Comment 2 Pratyush Sahay 2012-05-28 13:55:03 EDT
Created attachment 587277 [details]
image of the grub2 menu that shows up
Comment 3 Mads Kiilerich 2012-05-28 15:18:07 EDT
Please explain what 'blackish' and 'greyish' mean - attach comparable images that show the difference.

Anyway: Why is it a bug that it apparently looks different?
Comment 4 Pratyush Sahay 2012-05-28 22:41:09 EDT
Created attachment 587301 [details]
grub2 menu from RC4 install
Comment 5 Pratyush Sahay 2012-05-28 22:44:07 EDT
It seems to be more like a video mode issue. Its been classified as a bug because the video mode changes between installs from a F17 RC3 and from a F17 RC4.
Comment 6 Mads Kiilerich 2012-05-29 05:04:35 EDT
Fedora will now use graphical mode by default. 

It is not a bug that the video mode has changed.

Note You need to log in before you can comment on or make changes to this bug.