Bug 825871 - 'service dirsrv start' no longer works
'service dirsrv start' no longer works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: 389-ds (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 16:29 EDT by Edward Z. Yang
Modified: 2013-03-04 17:38 EST (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 17:38:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Z. Yang 2012-05-28 16:29:14 EDT
The 'service' binary is intended to work as a backwards-compatibility wrapper around systemd.  However, 'service start dirsrv' no longer works, because you must start dirsrv using 'systemctl start dirsrv.target', not 'systemctl start dirsrv.service'. The latter fails with "No such file or directory."
Comment 1 Rich Megginson 2012-06-01 15:27:18 EDT
If we were to support service, things like

service start dirsrv inst-name

would not work, nor is there a way to make it work, meaning the service command would work differently on systemd platforms and non-systemd platforms.  Is this acceptable?
Comment 2 Edward Z. Yang 2012-06-02 01:30:35 EDT
I don't mind if you don't support service; but it shouldn't fail silently. ;-)
Comment 3 Edward Z. Yang 2012-06-02 11:33:18 EDT
In particular:

[root@whole-enchilada ~]# service dirsrv stop
Redirecting to /bin/systemctl  stop dirsrv.service
[root@whole-enchilada ~]# echo $?
0
[root@whole-enchilada ~]# systemctl status dirsrv@scripts.service
dirsrv@scripts.service - 389 Directory Server scripts.
	  Loaded: loaded (/usr/lib/systemd/system/dirsrv@.service; enabled)
	  Active: active (running) since Thu, 31 May 2012 23:00:33 -0400; 1 day and 12h ago
	 Process: 2947 ExecStopPost=/bin/rm -f /var/run/dirsrv/slapd-%i.pid (code=exited, status=0/SUCCESS)
	 Process: 3292 ExecStart=/usr/sbin/ns-slapd -D /etc/dirsrv/slapd-%i -i /var/run/dirsrv/slapd-%i.pid -w /var/run/dirsrv/slapd-%i.startpid (code=exited, status=0/SUCCESS)
	Main PID: 3293 (ns-slapd)
	  CGroup: name=systemd:/system/dirsrv@.service/scripts
		  └ 3293 /usr/sbin/ns-slapd -D /etc/dirsrv/slapd-scripts -i /var/run/dirsrv/slapd-scripts.pid -w /var/run/dirsrv/slapd-scrip...
Comment 4 Rich Megginson 2012-07-31 13:58:22 EDT
Upstream ticket:
https://fedorahosted.org/389/ticket/423
Comment 5 Nathan Kinder 2013-03-04 17:38:32 EST
The silent failing issue was fixed in upstream ticket 457, which went out in 389-ds-base-1.2.11.15-1:

  https://fedorahosted.org/389/ticket/457

That said, the service command is not supported.

Closing this ticket.

Note You need to log in before you can comment on or make changes to this bug.