Bug 82591 - bootnet.img doesn't work with 3com pxe server
bootnet.img doesn't work with 3com pxe server
Product: Red Hat Linux
Classification: Retired
Component: anaconda-images (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-01-23 14:04 EST by Jason
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-05 23:03:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jason 2003-01-23 14:04:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I have used rawrite to create a bootable floppy using the bootnet.img file.  The
floppy boots the machine and I am able to install redhat from a ftp server. 
When I make a pxe image of the disk the resulting pxe image doesn�t work
properly.  The pxe image boots the PC, shows the splash screen, and waits for
the user to type linux, text, expert, etc.  I press enter to begin the install
and I get the following errors.  The first error I get is could not find ramdisk
image.  The next is could not find kernel image.  The bootnet.img file from
Redhat 7.3 works great using pxe.  Redhat 8's bootnet.img files doesn't want to
work from pxe.  I created the Redhat 8 pxe image the same way I did with 7.2 and
7.3.  I tried every possible combination of options to try to get it to work,
nothing worked.  Again the floppy I create using rawrite works.  So the problem
is probably with the way the 3com pxe server is reading the disk.  I used the
track copy option to create the pxe image, but the pxe image still doesn't work.
 Did something change in the way the bootnet.img works for redhat 8 compared
with redhat 7.3?

Basically I have about 36 PCs students need to install linux on.  I don't want
to keep burning CDs, so I started using the ftp install with 7.2.  I use PXE so
I don't have make floppies.  I use the 3Com PXE server which comes with Ghost
7.5 on a windows 2000 sp3 server.  Other pxe images work fine.  Redhat 7.x pxe
image (using 7.x bootnet.img file) works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Create boot disk from redhat 8 bootnet.img using rawrite
2.  boot computer to verify floppy was created correctly
3.  use 3com pxe server to make pxe image of floppy
4.  try to boot using pxe image of floppy
5.  errors appear about not finding kernel or ramdisk images

Actual Results:  the install could not start

Expected Results:  the install should have started

Additional info:
Comment 1 Jason 2003-01-27 16:50:28 EST
This is also a problem in Phoebe.  I downloaded the bootdisk.img and made a 
floppy.  The floppy version worked, but I get the same errors as above when I 
try to use the 3Com PXE server.
Comment 2 Jeremy Katz 2003-01-29 16:57:54 EST
What is this "3com pxe server"?  Is it something we ship?
Comment 3 Jason 2003-01-29 17:23:20 EST
No you don't make the pxe server.  3Com does.  Basicly, PXE is a way for a PC 
to boot without having to use a floppy disk.  When the PC boots, the PCs 
downloads a menu of bootable images from which the user can choose.  The user 
chooses and the image of the software is sent to the PC.  I have a menu file 
that allows the user to install redhat 7.3 from our ftp server.  When I setup 
the menu to install redhat 8, the PC boots from the image, but it can't find 
the ramdisk or kernel images.

Redhat seems to have changed the way the bootnet.img bootdisk works between 7.3 
and 8.0.  Using the 3Com software I can make an image from a bootable floppy 
that the PCs can use to boot from.  I use this method so I don't have to make 
60 CDs or 20 floppies for the students to do an ftp install of redhat.  In 7.3 
I used rawrite to create a boot disk from the bootnet.img file.  I tested the 
floppy by booting a PC from it.  The install went fine.  I then used the 3Com 
software to make an image of the floppy (track by track) so the PCs could use 
that image to boot from.  In 7.2 and 7.3 this worked.  The PC boots just like a 
floppy was in the drive.  The student presses enter and install works.  

I followed the same procedure using the redhat 8 bootnet.img.  The floppy boots 
the PC fine and the install works.  However when I use the 3Com software to 
make the image, the resulting image boots but I can't install redhat 8.  I 
downloaded the beta of 8.1 used rawrite to create a floppy using the 
bootdisk.img file and again the floppy works but the 3com image doesn't.  I get 
the error messages "could not find ramdisk image" and "could not find kernel 
image".  Something changed in the way the bootnet.img and bootdisk.img files 
were created.  Are the bootnet and bootdisk files using hard coded path names 
now (i.e. /dev/fd0/initrd.img)? What changes were made to bootnet.img from 7.3 
to 8 and 8.1?  
Comment 4 Michael Fulbright 2003-01-31 17:43:16 EST
You can look at the syslinux.cfg on all of these images - we haven't changed
anything except perhaps the size of the ramdisk needed for the initrd.
We're probably using a newer version of syslinux as well.  Not sure how this
would interact with the 3com PXE server.

Comment 5 Jason 2003-02-04 19:49:09 EST
I sat down and worked on this for 2 hours today.  I downloaded the latest 
syslinux 2.0.1 installed it on the floppy disk.  The floppy booted and 
everything installed like it did on the other attempts.  I then made the PXE 
image of the disk and it failed again.  I then tried altering the options on 
the append line.  I change initrd=initrd.img to initrd= and the system booted 
but crashed as follows:

ext2_fs: unable to read superblock
cramfs: wrong magic
fat: unable to read boot sector
isofs_read_super: bread failed, dev=09:02, iso_blknum=16, block=32
kernel panic: VFS: unable to mount root fs

This leads to think that the problem I am having is somehow related to the 
ramdisk.  The system boots and crashes without the ramdisk, and just crashes 
with the ramdisk.  If you have any ideas please let me know.  I am going to try 
to examine the ramdisk tomorrow if I have time.  I hope the above messages give 
you something to work on.
Comment 6 Jason 2003-02-05 23:03:43 EST
I spent about an hour looking at the kernel and the ramdisk and they are fine.  
I turned my attention to syslinux.  It took me 3 hours to go through all of the 
versions, but the problem is with syslinux.  Versions 1.6x, 1.71, and 1.72 
work, and the rest don't.  I will contact the syslinux people to report the 
problem.  Thanks for your time.

Note You need to log in before you can comment on or make changes to this bug.