Bug 82594 - Upgrade 7.3 to 8.0. redhat-config-xfree86 hangs.
Upgrade 7.3 to 8.0. redhat-config-xfree86 hangs.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-23 15:04 EST by Gustav Schaffter
Modified: 2007-04-18 12:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 15:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustav Schaffter 2003-01-23 15:04:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Upgraded from a working RH 7.3 with X (all erratas applied) to 8.0.

X fails to start with the error:

Fatal server error:
AddScreen/ScreenInit failed for driver 0

Full X log can be provided on request.


Tried to run redhat-config-xfree86, but this *almost* hangs the PC.
With 'almost' I mean that a simple beep on the speaker takes 5 to 10 seconds, a
shutdown takes more than five minutes, top doesn't update, etc.

What I consider as bugs:
1. redhat-config-xfree86 'almost' hangs the PC.
2. A working 7.3 installation broke when upgrading to 8.0
3. redhat-config-xfree86 should be able to setup my PC at least to std VGA mode.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade from 7.3 to 8.0
2.run redhat-config-xfree86
3.
    

Actual Results:  X fails to start and the computer almost hangs.

Expected Results:  X should have continued to work as before the upgrade and/or
redhat-config-xfree86 should be able to setup my PC to at least std VGA mode
(from where I could manually re-configure X to different resolutions).


Additional info:

Video card: Built-in on motherboard, S3.

Monitors tried:
1. Microscan 4G/ADI
2. SHARP LCD monitor LL-1510A

The problem is the same with any of the above monitors. Under 7.x, both monitors
worked perfect. The Microscan was once directly recognized bu Xconfigurator. The
SHARP monitor worked perfectly well when I let Xconfigurator choose Std LCD (or
something like that).
Comment 1 Gustav Schaffter 2003-01-26 06:57:41 EST
So, to advance this matter, I put in the installation diskette, containing the
BOOTNET.IMG image for RH8.0 and rebooted.


Output in tty1:

Probing for video card: S3 Trio64V2 (generic)
Probing for monitor type: Unable to probe
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5....X SERVER FAILEDAttempting to start VESA driver X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.


Output in tty3:

*ddcprobe returned bogus values:
ID:   SHP2045
Name: LL-T1510A
HorizSync: -268377405--268435203
VertSync:  -268435203--268370092

* Probing for monitor type: Unable to probe
* Probing for mouse type:   Generic - 3 Button Mouse (PS/2)
* forcing dpi = 96 for mode 800x600, heightxwidth = 211.666666667mm by 158.75mm
* forcing dpi = 96 for mode 800x600, heightxwidth = 211.666666667mm by 158.75mm
* Starting mini-wm
* anaconda floppy device fd0



In tty7 I have a broken display of a broken X showing a very distorted "Welcome
to Red Hat Linux" screen. When I look upon this screen, I get automatically
switched to tty6 after about 5 seconds.


In tty6 I have a working X server with a clean "Welcome to Red Hat Linux" screen
from where I can continue the installation, which I also did when upgrading from
RH7.3 to RH8.0.


I'm stubborn and I insist that since anaconda was able (with some difficulties)
to get the X server up and running with the VESA driver, I should have got a
working system after the upgrade.

I might have had to tweak the X configuration myself to get the whished screen
resolutions etc. but I'd expect a system where X could successfully start.

And I'd expect that redhat-config-xfree86 would not 'almost' hang the computer,
but either silently fail or, even better, tell me that it's failing in a
controlled way.
Comment 2 Gustav Schaffter 2003-02-01 06:24:57 EST
I may add that the RH7.3 installation shows no problem in getting the system
going. X starts up at first try during the installation.

Output in tty1:

Probing for video card: S3 Trio64V2 (generic)
Probing for monitor type: LL-T1510A
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.


Output in tty7:
A working X server with a clean "Welcome to Red Hat Linux" screen
from where I can continue the re-installation of RH7.3.
(Which I will soon have to do, lacking any form of feedback in this matter.)
Comment 3 Brent Fox 2003-02-11 15:39:18 EST
Gustav: I've read this report numerous times but I'm unable to really figure out
where the problem might be.  When you put the 8.0 cd in the machine and started
up the system to do the upgrade, did the installer graphical screen appear and
did it look correct?
Comment 4 Gustav Schaffter 2003-02-12 14:40:49 EST
In tty7 it shows up but looks broken and is not responsive. OTOH, in tty6 (!) I
find a fully working "installer graphical screen" that looks "correct". This is
also the one I used for the upgrade.

If I manually switch to tty7, the system will automagically switch over to tty6
after about 5 to 10 seconds.
Comment 5 Mike A. Harris 2003-02-12 22:42:22 EST
This looks like a problem in the mechanism that is being used to do DDC
probing IMHO.  How has this changed since Red Hat Linux 7.3?
Comment 6 Brent Fox 2003-02-13 11:14:47 EST
None, as far as I know.  Alex, are you aware of any changes to ddcprobe since 7.3?
Comment 7 Alexander Larsson 2003-02-13 11:36:08 EST
not that i know, but you should ask someone more involved in kudzu development.
Comment 8 Brent Fox 2003-02-18 17:30:26 EST
notting: any idea if ddcprobe has changed since 7.3?
Comment 9 Bill Nottingham 2003-02-18 19:41:05 EST
No changes between 7.3 and 8.0
Comment 10 Brent Fox 2003-05-27 15:38:58 EDT
Sigh.  I haven't had any luck reproducing this problem.  I'm going to close this
as 'worksforme' because I can't seem to get a reproducible test case.

Note You need to log in before you can comment on or make changes to this bug.