Bug 826069 - qcow2 image not detected correctly by lvm
qcow2 image not detected correctly by lvm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 10:08 EDT by Tomas Rusnak
Modified: 2012-05-30 11:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 11:40:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.30 KB, text/plain)
2012-05-29 10:09 EDT, Tomas Rusnak
no flags Details
storage.log (42.38 KB, text/plain)
2012-05-29 10:09 EDT, Tomas Rusnak
no flags Details
install.log (16.43 KB, text/plain)
2012-05-29 10:10 EDT, Tomas Rusnak
no flags Details
program.log (4.75 KB, text/plain)
2012-05-29 12:22 EDT, Tomas Rusnak
no flags Details

  None (edit)
Description Tomas Rusnak 2012-05-29 10:08:38 EDT
Description of problem:
When I tried to install RHEL6 as a guest on RHEL6 host with qcow2 image as a storage, the graphics installer ends with:
1. auto-partitioning - message "no enough space to install"
2. manual partitioning - it refuse /dev/vda1 for creating LVM volume group (but is there available)

Version-Release number of selected component (if applicable):
RHEL6.x

How reproducible:
100%

Steps to Reproduce:
1. qemu-img create -f qcow2 rhel6_64.img 10G
2. set that image in guest and boot RHEL6 from PXE 
3. go over graphical installation process
4. try to repartition automatically or by hand
  
Actual results:
/dev/vda is not detected by LVM manager correctly => system cannot be installed

Expected results:
system can be installed on qcow2 images

Additional info:
The workaround is to create raw image, install RHEL and then convert it into qcow2 format - I tested this.
Comment 1 Tomas Rusnak 2012-05-29 10:09:13 EDT
Created attachment 587419 [details]
anaconda.log
Comment 2 Tomas Rusnak 2012-05-29 10:09:37 EDT
Created attachment 587420 [details]
storage.log
Comment 3 Tomas Rusnak 2012-05-29 10:10:15 EDT
Created attachment 587421 [details]
install.log
Comment 5 Chris Lumens 2012-05-29 10:50:48 EDT
Can you also attach syslog and program.log?  Thanks.
Comment 6 Tomas Rusnak 2012-05-29 12:22:12 EDT
Created attachment 587444 [details]
program.log

I haven't syslog backed up from this run. Sorry. But I can reproduce it againt, if it still can help.

Also, I found my mistake while I did it by hand. By hand it's installable without problem. The problem with auto-repartitioning is still here.
Comment 7 David Lehman 2012-05-29 12:52:22 EDT
Please attach your kickstart config script.

What is the exact error or failure you are seeing? Is the problem that your %pre script is failing or what?
Comment 8 Tomas Rusnak 2012-05-30 07:39:44 EDT
As I wrote, I did manual install - graphical one, there was no kickstart used. Installation ask you for type of installation - I choose first option "Use All Space". 
After that you can see "Error Partitioning" titled window with message: "not enough space for LVM requests. Press 'OK' to exit the installer".
Comment 12 Tomas Rusnak 2012-05-30 10:13:28 EDT
> Interactive in the kickstart sense means it takes the kickstart file, applies
> it, and then allows you to step through the graphical install anyway and make 
> changes.  It is also extremely error prone and we don't recommend people use it.

> My suggestion is you try the same install without the "interactive" line in the 
> kickstart file and see if that clears everything up.

I tried same install without interactive and it's working without any problem. Then the problem should be with that interactive ks file, which was used from PXE. It can be installed with manual partitioning anyway. Thx for explanation. Please close this bug.

Note You need to log in before you can comment on or make changes to this bug.