Bug 826142 - Document rhui-manager status return codes
Document rhui-manager status return codes
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Documentation (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Julie
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 13:21 EDT by James Slagle
Modified: 2012-08-24 09:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A table of all possible rhui-manager status return codes is missing from the Red Hat Update Infrastructure (RHUI) Administration guide. Table 10.1 was added to Chapter 10 Monitoring. Users can now refer to Table 10.1 for status code meanings.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-05-29 13:21:54 EDT
Document the possible return codes from 'rhui-manager status'
Comment 1 James Slagle 2012-06-11 13:07:20 EDT
We need to add the following content to Chapter 12. Monitoring in the Installation guide:

 * Status return codes - The `rhui-manager status` command now returns
   meaningful return codes.  If there are multiple problems, the return codes
   are logically OR'd together so that it can be determined exactly what went
   wrong.  The return codes are:
   ** Ok = 0
   ** Repository sync error = 1
   ** CDS sync error = 2
   ** CDS heartbeat error = 4
   ** Identity certificate expiration warning = 8
   ** Identity certificate expiration error = 16
   ** Entitlement CA certificate expiration warning = 32
   ** Entitlement CA certificate expiration error = 64


Feel free to reformat as needed and let me know if you have any questions.  thanks.
Comment 5 Julie 2012-08-15 00:31:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A table of all possible rhui-manager status return codes is missing from the Red Hat Update Infrastructure (RHUI) Administration guide. Table 10.1 was added to Chapter 10 Monitoring. Users can now refer to Table 10.1 for status code meanings.
Comment 7 errata-xmlrpc 2012-08-24 07:54:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.