Bug 826191 - upowerd spams logs with warning msg about /proc/timer_stats
upowerd spams logs with warning msg about /proc/timer_stats
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 14:47 EDT by Martin Langhoff
Modified: 2017-04-09 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 11:17:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Langhoff 2012-05-29 14:47:15 EDT
Description of problem:

The kernel we currently include in OLPC XO builds of F17 does not have /proc/timer_stats . 

Kernel docs for /proc/timer_stats indicate it's a debugging/diagnostic tool http://www.kernel.org/doc/Documentation/timers/timer_stats.txt

It makes sense to issue a warning of timer_stats is not present. We currently get 6 warnings per second.
 
Version-Release number of selected component (if applicable):

upower 0.9.16-1fc17

How reproducible:

100%

Steps to Reproduce:
1. Build a kernel without timer_stats
2. Watch your logs
3.
  
Actual results:

6 messages per second

Expected results:

1 warning message per powerd run

Additional info:
Comment 1 Richard Hughes 2012-10-03 11:17:46 EDT
commit fd32f0be0f16b9420bdecd57d4a0cdcfc3882960
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Oct 3 16:20:20 2012 +0100

    Do not continue to poll if /proc/timer_stats is not readable
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=826191
Comment 2 Martin Langhoff 2012-10-03 12:20:36 EDT
Thank you!
Comment 3 Martin Langhoff 2012-10-03 12:24:03 EDT
Ah, I see the fix is "upstream". ETA for landing in a release/build in Fedora?
Comment 4 Richard Hughes 2012-10-03 13:32:50 EDT
(In reply to comment #3)
> Ah, I see the fix is "upstream". ETA for landing in a release/build in
> Fedora?

If you can verify it fixes the bug, I'll do a new upstream release next week.
Comment 5 Martin Langhoff 2012-10-03 19:34:23 EDT
I am trying to verify this, but I ran into something very strange.

We found this issue in May, with F17 reasonably stable, while looking at other upower-related things. Between that and OLPC's OS release ("12.1.0") upower did not change, we did not add /proc/timer_stats and our upower config did not change either. Yet the behaviour seems to have vanished, or rather, I cannot repro it.

I spent a couple hours today trying to repro it on our final 12.1.0 with various configurations -- XO-1.5, XO-1.75, full battery, low battery, etc. I can probably go back to the exact build I used back in May and bisect it to which build it disappeared in, but that's very time-consuming.

Perhaps you can help me repro. Is this codepath conditional on something else?
Comment 6 Richard Hughes 2012-10-04 07:15:56 EDT
(In reply to comment #5)
> Perhaps you can help me repro. Is this codepath conditional on something
> else?

Yes, hence why I was surprised by this bug. Try running something like gnome-power-statistics that uses the interface for stats reporting.
Comment 7 Christian Stadelmann 2017-04-09 05:04:00 EDT
This issue is still present (or again). Might also be caused by https://bugs.freedesktop.org/show_bug.cgi?id=100626. Anyway, with upower-0.99.4-2.fc25.x86_64, I can reproduce these steps:
1. start gnome-power-manager
2. have a look at syslog

What happens:
Syslog is spammed by the warning specified in https://cgit.freedesktop.org/upower/tree/src/up-wakeups.c#n467

What should happen:
Logging this once is enough.

Note You need to log in before you can comment on or make changes to this bug.