Bug 8262 - DNS lookup
DNS lookup
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: apache (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks: 958
  Show dependency treegraph
 
Reported: 2000-01-07 06:30 EST by osman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-13 17:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description osman 2000-01-07 06:30:41 EST
Minor:
It seems that the NoProxy directive can handle multiple arguments seperated
by a comma.

Major:
When you use the <Directory proxy:*> directive as distributed with the last
version(s).
There is an error with the handling of the allow from directive.
It doesn't do DNS ! So you can't use canonical names. It works when you use
IP#'s.
Is this a bug in the proxy module or did something else broke?
Maybe it's best you forward this to the apache development team...?
Comment 1 osman 2000-01-10 02:10:59 EST
It seems that this bug is not actualy in the proxy module (IMHO).
The symptom is available in all Allow from directives and perhaps similars.
I just found out it had problems with the allow from because it stoped allowing
an internal lan machine from accessing wich it allowed before with the same
config.
Comment 2 Preston Brown 2000-01-13 17:18:59 EST
this is actually a feature.  DNS lookups are off in apache for performance
reasons.  Otherwise, each access would result in a DNS lookup, which is VERY
SLOW relative to other operations.

You can enable them though if you wish.  Please read the apache manual.

Note You need to log in before you can comment on or make changes to this bug.