Bug 826236 - Error in PREIN scriptlet
Error in PREIN scriptlet
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 16:20 EDT by cornel panceac
Modified: 2012-12-24 01:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-24 01:24:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2012-05-29 16:20:48 EDT
Description of problem:
attempting to install rpcbind , i get this error:

Running Transaction
Error in PREIN scriptlet in rpm package rpcbind-0.2.0-16.fc17.i686
error: %pre(rpcbind-0.2.0-16.fc17.i686) scriptlet failed, exit status 6
  Verifying  : rpcbind-0.2.0-16.fc17.i686                                                                                                  1/1 

Failed:
  rpcbind.i686 0:0.2.0-16.fc17                                                                                                                 

Complete!


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
attempting to install nfs-utils, i get:
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
1:nfs-utils-1.2.6-0.fc18.i686 has missing requires of rpcbind
3:ypbind-1.35-2.fc18.i686 has missing requires of rpcbind
Comment 1 Ken Dreyer 2012-08-13 13:58:43 EDT
I'm getting this error on F17 as well. It's preventing me from updating nfs-utils, since nfs-utils-1:1.2.6-4.fc17 wants rpcbind.

"%pre(rpcbind-0.2.0-16.fc17.i686) scriptlet failed, exit status 6"
Comment 2 Ken Dreyer 2012-08-13 14:03:18 EDT
I manually ran the code in the %pre script:

# getent passwd rpc | cut -d: -f 3
(shows nothing)

# /usr/sbin/groupadd -o -g 32 rpc
# /usr/sbin/useradd -o -l -c "Rpcbind Daemon" -d /var/lib/rpcbind -g 32 -M -s /sbin/nologin -u 32 rpc

And then I could install rpcbind with yum. I'm not sure why the %pre script fails in RPM, but succeeds when I run the code manually in a root shell.
Comment 3 Dan Mashal 2012-09-30 18:34:03 EDT
I was able to reproduce:

  Updating   : 3:ypbind-1.36-6.fc17.x86_64                               98/217 
/var/tmp/rpm-tmp.5FWr5L: line 7: fg: no job control
Comment 4 Dan Mashal 2012-12-24 01:24:36 EST
This seem to be fixed. Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.