Bug 826278 - SELinux is preventing /usr/sbin/usermod from 'setattr' accesses on the file /home/jonathan/.mozilla/plugins/libflashplayer.so.
SELinux is preventing /usr/sbin/usermod from 'setattr' accesses on the file /...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:68e1c3d04e78158ac8770fb6185...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 18:12 EDT by Jonathan Gazeley
Modified: 2012-06-22 07:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 07:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Gazeley 2012-05-29 18:12:20 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Tue 29 May 2012 11:11:08 PM BST

description:
:SELinux is preventing /usr/sbin/usermod from 'setattr' accesses on the file /home/jonathan/.mozilla/plugins/libflashplayer.so.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that usermod should be allowed setattr access on the libflashplayer.so file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep usermod /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:textrel_shlib_t:s0
:Target Objects                /home/jonathan/.mozilla/plugins/libflashplayer.so
:                              [ file ]
:Source                        usermod
:Source Path                   /usr/sbin/usermod
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           shadow-utils-4.1.4.3-14.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.7-1.fc17.x86_64 #1 SMP Mon May 21 22:32:19 UTC
:                              2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Tue 29 May 2012 10:19:41 PM BST
:Last Seen                     Tue 29 May 2012 10:19:41 PM BST
:Local ID                      d30e3013-ffc1-404c-b590-c755692c4729
:
:Raw Audit Messages
:type=AVC msg=audit(1338326381.148:257): avc:  denied  { setattr } for  pid=25293 comm="usermod" name="libflashplayer.so" dev="md0" ino=11011871 scontext=unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:textrel_shlib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338326381.148:257): arch=x86_64 syscall=lchown success=no exit=EACCES a0=7fffda399580 a1=1f4 a2=3e8 a3=7fd42a59bc79 items=0 ppid=25220 pid=25293 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=6 comm=usermod exe=/usr/sbin/usermod subj=unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: usermod,useradd_t,textrel_shlib_t,file,setattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-30 04:38:05 EDT
How does the command look which you execute?
Comment 2 Jonathan Gazeley 2012-05-30 05:00:36 EDT
As root user, I executed: usermod -g 500 jonathan

(Because I reinstalled my PC with Fedora 17 and my "jonathan" account came back with uid 1000. I re-numbered it to match my user account on other machines).

Note You need to log in before you can comment on or make changes to this bug.