This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 82629 - Xterm unstable in beta4
Xterm unstable in beta4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-24 01:33 EST by Chris Ricker
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 02:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-01-24 01:33:05 EST
I work all day long in X on my laptop with xterms (xterm -geometry 80x50 -sb -sl
9999 -fn fixed) covering the screen.

In beta4, xterm is extremely unstable. After I start X and my initial terminals
get launched, roughly 50% of the time one or more of the terminals will exit
approximately a minute after first appearing on the screen. They've died while
I'm working in them, but also before I even get a chance to run any commands in
them (so its something inherent to xterm or the X server, and not a program I'm
running in them that's killing them)

No errors appear in /var/log/X* log files about this

This is new in beta 4 -- xterm worked fine in previous betas

This is only seen on my laptop so far (but I've been on the road all week, so
its all I've run beta4 on...). The laptop has a Trident Cyberblade chipset and
is running at 1024x768x24. I'm running gnome w/ metacity as the wm

I've got core dumps enabled now, so if one dumps core next time it happens, I'll
attach that
Comment 1 Mike A. Harris 2003-01-24 08:30:51 EST
Please do.  We don't officially support xterm, however from your bug
report alone it is inconclusive if it is an xterm bug, Xlib bug, glibc,
some other X library, kernel, NPTL, or something else perhaps.

Update with any info you can muster.  If you get a core dump, don't attach the
core, but attach a backtrace instead.

TIA
Comment 2 Kjartan Maraas 2003-02-10 09:22:06 EST
FYI. No problems with xterm here so far using the latest rawhide packages from
2003-02-10
Comment 3 Mike A. Harris 2003-02-10 09:30:08 EST
Thanks for the update Kjartan.  With this update, I'm assuming whatever
problem may have been present is no longer present.  Nobody else has
reported any xterm stability issues, and I can't reproduce any stability
problems while running our latest tree and using xterm for hours to work
with.  I know many other Red Hatters use xterm as their primary terminal
as well, so I'd hear a ruckus if something were amiss.  ;o)

Assuming that the problem is fixed now whatever it was and changing
bug state to MODIFIED pending final confirmation from Chris that it is
working for him now.  Please set to RAWHIDE if it works, or back to
ASSIGNED if not.

TIA
Comment 4 Chris Ricker 2003-02-19 23:03:42 EST
I still had some (though not as many) segfaults with pre-beta5. I've got beta5
installed on my road machine now, so I'll see how it does over the next couple
of days....
Comment 5 Chris Ricker 2003-06-18 02:02:35 EDT
Cleaning up old bugs -- this one seems fixed now, thanks

Note You need to log in before you can comment on or make changes to this bug.