Bug 826310 - Usability: Manage Search (Re-index)
Usability: Manage Search (Re-index)
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity low
: ---
: 1.6.2
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 21:02 EDT by Sean Flanigan
Modified: 2012-11-29 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.6.2-SNAPSHOT (20120723-0001)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 18:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-05-29 21:02:03 EDT
Usability: 

Re-index full text search database feature
 - should have an option to select all
 - should explain options (Purge index, Reindex, Optimize)

Also, Class should probably be renamed to Table.  (It's both, but Table is probably easier to explain.)

Version-Release number of selected component (if applicable):
Zanata version 1.6.0-beta-2-SNAPSHOT (20120530-0019)
Comment 1 Sean Flanigan 2012-05-30 01:21:45 EDT
One other thing: The button "Re-index full text search database" should be renamed, because the action taken depends on which check-boxes in the table have been selected.  (And it does nothing if none are selected.)

Perhaps we should grey out the existing button until something has been selected, call it something like Perform Selected Actions, and add another button which does everything, eg "Perform All Actions (SLOW)".
Comment 2 David Mason 2012-06-25 00:38:24 EDT
Workaround: until a select-all button is added, some may find using Tab and Space easier than mouse clicks. The first checkbox can be focused by clicking in the project search box and pressing Tab twice.
Comment 3 David Mason 2012-06-25 21:33:12 EDT
Should also have option to abort an in-progress operation.
Comment 4 David Mason 2012-06-27 03:19:44 EDT
Updated button to read "Perform Selected Actions", changed "Class" to "Table" and added tooltips to checkboxes, including warnings about memory use, time, etc.

See: https://github.com/zanata/zanata/commit/bccd332f4a4bfd52148717834e7d07354f905c4a
Comment 5 David Mason 2012-07-02 03:34:00 EDT
Added remaining enhancements:
 - shows elapsed time
 - shows estimated remaining time
 - increased progress bar size
 - "Select All" and "Clear Selection" buttons
 - shows currently processing class name
 - "Abort" button


If there is an error or the operation is aborted, progress indicator and currently processing class name remain visible to provide information about the partially complete process.

See: https://github.com/zanata/zanata/compare/0fedf4c9d1633a322259431433fa135f754f924d...d8c90207400a78e38b3ebb00c0113b08b4a4fa0e
Comment 7 Ding-Yi Chen 2012-07-22 22:11:19 EDT
VERIFIED with Zanata version 1.7.0-alpha-2-SNAPSHOT (20120723-0951)
and Zanata version 1.6.2-SNAPSHOT (20120723-0001)

Note You need to log in before you can comment on or make changes to this bug.