Bug 826327 - Need extra OSGi information for eclipse (patch)
Need extra OSGi information for eclipse (patch)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: javamail (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 22:56 EDT by Gerard Ryan
Modified: 2012-06-25 20:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 06:07:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Add-additional-information-to-OSGi-manifest.patch (4.00 KB, patch)
2012-05-29 22:56 EDT, Gerard Ryan
no flags Details | Diff

  None (edit)
Description Gerard Ryan 2012-05-29 22:56:30 EDT
Created attachment 587581 [details]
0001-Add-additional-information-to-OSGi-manifest.patch

Description of problem:

OSGi bundle javax.mail is needed for eclipse-wtp-webservices, which I'm trying to build.

Description of patch (attached):
1. Info added to OSGi Manifest
2. Fixed complaint from rpmlint about %{_mavendepmapfragdir}/*
Comment 1 Gerard Ryan 2012-05-30 08:41:32 EDT
By the way, this is what gets changed in the spec for the mavendepmapfragdir part:

-%config(noreplace) %{_mavendepmapfragdir}/*
+%{_mavendepmapfragdir}/*

I removed the %config(noreplace), since that was what was causing the warning. I assume it was something old, is it needed any more? If so, let me know, I'll redo the patch.
Comment 2 Mikolaj Izdebski 2012-06-13 06:07:59 EDT
This should be fixed now. Thank you for the patch!
Comment 3 Fedora Update System 2012-06-15 08:36:26 EDT
javamail-1.4.3-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/javamail-1.4.3-11.fc17
Comment 4 Fedora Update System 2012-06-25 20:50:13 EDT
javamail-1.4.3-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.