Bug 826366 - Large file creates and rewrites slower in 3.3.0qa44
Large file creates and rewrites slower in 3.3.0qa44
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-05-30 00:38 EDT by Anush Shetty
Modified: 2013-12-18 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:36:13 EDT
Type: Bug
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-05-30 00:38:59 EDT
Description of problem: Large file creates and rewrites are slower in 3.3.0qa44 compared to 3.3.0qa43.

In 3.3.0qa43, large file creates took 30s and in 3.3.0qa44 it takes 40s


Version-Release number of selected component (if applicable): 3.3.0qa44


How reproducible: Consistently


Steps to Reproduce:
1. Large file tests in git://github.com/avati/perf-test.git
2.
3.
Comment 1 Amar Tumballi 2012-05-30 01:08:11 EDT
Looks like a regression with SELinux enabling. Vijay is working on confirming that, will report back after one round of testing.
Comment 2 Amar Tumballi 2012-05-30 02:06:54 EDT
with patch http://review.gluster.com/3487 http://review.gluster.com/3485 this regression is solved.
Comment 3 Anush Shetty 2012-05-30 09:51:23 EDT
Verified with 3.3.0qa45

Note You need to log in before you can comment on or make changes to this bug.