This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 826388 - [mvn] Glossary-push compendium PO file: option -Dzanata.glossaryFile failed to recognize tilde (~)
[mvn] Glossary-push compendium PO file: option -Dzanata.glossaryFile failed t...
Status: CLOSED CANTFIX
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
1.6-SNAPSHOT
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 02:13 EDT by Ding-Yi Chen
Modified: 2013-03-03 21:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 02:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-05-30 02:13:31 EDT
Version-Release number of selected component (if applicable):
1.6.0-beta-2-SNAPSHOT (20120530-0019)

Steps to Reproduce: 
1. run:
mvn zanata:glossary-push -Dzanata.glossaryFile=~/Downloads/compendium-zh_TW-stamp20120529-c.po -Dzanata.transLang=zh-Hant -Dzanata.url=<zanataServerUrl>

Actual results: 
[INFO] Glossary file: <myWorkingDir>/~/Downloads/compendium-zh_TW-stamp20120529-c.po

Expected results:
~ should resolve as $HOME, i.e. 

[INFO] Glossary file: <$HOME>/Downloads/compendium-zh_TW-stamp20120529-c.po
Comment 1 Sean Flanigan 2012-05-30 02:28:36 EDT
Unfortunately, Java and Maven do not support expanding the tilde (~) character to $HOME.  Thus, since the path does not start with "/", it is treated as a relative path.

Workaround:
  mvn zanata:glossary-push -Dzanata.glossaryFile=$HOME/Downloads/compendium-zh_TW-stamp20120529-c.po -Dzanata.transLang=zh-Hant -Dzanata.url=<zanataServerUrl>

Note You need to log in before you can comment on or make changes to this bug.