Bug 826456 - Add maven-compiler-plugin settings to RichFaces Showcase
Add maven-compiler-plugin settings to RichFaces Showcase
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: RichFaces (Show other bugs)
2.0.0.ER6
All Unspecified
medium Severity low
: ---
: 2.0.0.ER8
Assigned To: Marek Novotny
Pavol Pitonak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 04:56 EDT by Lukáš Fryč
Modified: 2016-07-03 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch for the issue (1018 bytes, patch)
2012-05-30 06:35 EDT, Lukáš Fryč
no flags Details | Diff
Patch for moving the settings out of release profile (2.20 KB, patch)
2012-06-05 10:04 EDT, Lukáš Fryč
no flags Details | Diff

  None (edit)
Description Lukáš Fryč 2012-05-30 04:56:04 EDT
Description of problem:
The showcase is missing maven-compiler-plugin settings, which causes Eclipse to treat the project as compilation level = 1.5.

This is not reproducible in community version since it has parent specified which contains plugin's management.

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. Import the showcase to JBDS
2. open project settings > Java Compiler
3. Compiler compliance level == 1.5
  
Actual results:
Compiler compliance of the imported project = 1.5

Expected results:
Compiler compliance of the imported project = 1.6

Additional info:
Comment 1 Lukáš Fryč 2012-05-30 06:35:26 EDT
Created attachment 587675 [details]
The patch for the issue
Comment 2 Marek Novotny 2012-05-30 09:17:30 EDT
applied patch
Comment 3 Pavol Pitonak 2012-06-05 05:48:01 EDT
Lukas, it is set in profile "release", shouldn't it be set for each profile?
Comment 4 Lukáš Fryč 2012-06-05 09:36:13 EDT
Confirmed, I have accidentally added configuration to release profile.
Comment 5 Lukáš Fryč 2012-06-05 10:04:48 EDT
Created attachment 589533 [details]
Patch for moving the settings out of release profile

Attached patch for moving the settings out of release profile

Note You need to log in before you can comment on or make changes to this bug.