Bug 826512 - [FEAT] geo-replication checkpoint support
[FEAT] geo-replication checkpoint support
Status: CLOSED NEXTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Csaba Henk
: FutureFeature
: 921391 (view as bug list)
Depends On:
Blocks: 850514
  Show dependency treegraph
 
Reported: 2012-05-30 07:43 EDT by Csaba Henk
Modified: 2013-05-08 05:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Get feedback on sync state of geo-replication. User can specify a "checkpoint", a record of the master state as of the time. User will get info when the "checkpoint is reached", ie. when data present on master at the time of the checkpoint record is synced over to slave. Reason: Before this, we had _zero_ feedback on sync state, which is an utter antifeature. Result (if any): Works fine, though reports are mixed because the crucial bugfix of http://review.gluster.org/4248 got some delay in reaching customers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 03:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2012-05-30 07:43:32 EDT
Description of problem:

We need some feedback on the progress of a geo-rep a session.
Intuitively, one would like to know when the synchronization
completes. Alas, in real life use cases, changes are made
continuously, so a point of completion will never be reached.

However, it make sense to ask that given a certain timepoint,
when do we arrive to a state when all master side data has a
replica on slave that is no older than the timepoint.

Geo-rep checkpointing will be an UI enhancement that gives
an interface to ask and answer this question.

"Asking" is called "setting a checkpoint" which makes a note
of master's xtime at the given moment. When the above referred
sync state is reached, that we call the "completion of the
checkpoint" or "reaching the checkpoint".

"Answering" happens by providing info in geo-rep status
output about checkpoint completion.
Comment 1 Vijay Bellur 2013-01-22 01:26:08 EST
CHANGE: http://review.gluster.org/3919 (geo-rep / glusterd: do non-blocking connect to checkpoint service) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Csaba Henk 2013-05-08 05:22:46 EDT
*** Bug 921391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.