Bug 826519 - cups 1.5.3-2.fc17 interferes with udisksctl unmount
cups 1.5.3-2.fc17 interferes with udisksctl unmount
Status: CLOSED DUPLICATE of bug 747114
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 08:01 EDT by Edward Sheldrake
Modified: 2012-09-19 04:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 04:52:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2012-05-30 08:01:43 EDT
Description of problem:
After installing the recent cups testing update, "udisksctl unmount" fails to remove the directory created for a mounted USB disk.

Version-Release number of selected component (if applicable):
cups-1.5.3-2.fc17.x86_64

How reproducible:
Reproducible - after some further testing, I think cups prevents udisksd cleaning up the directory for USB disks that were mounted when cups was started.

Steps to Reproduce:
1. systemctl stop cups.service
2. Mount a USB disk with "udisksctl mount"
3. open a print dialog to auto start the cups service
4. Unmount the USB disk with "udisksctl unmount"
  
Actual results:
The disk is unmounted but the directory created remains.
May 30 12:36:23 obsidian udisksd[1155]: Cleaning up mount point /run/media/ejs/UDISK 2.0 (device 8:17 is not mounted)
May 30 12:36:23 obsidian udisksd[1155]: Error cleaning up mount point /run/media/ejs/UDISK 2.0: Error removing directory: Device or resource busy

Expected results:
The directory gets removed.

Additional info:
If you mount the USB disk again, it gets mounted in a new directory with a 1 appended to the name. And then udisks2 gets confused about what to unmount:

$ ls -l /run/media/ejs/
total 16
drwx------ 2 root root    40 May 30 12:35 UDISK 2.0
drwx------ 8 ejs  ejs  16384 Jan  1  1970 UDISK 2.01

$ udisksctl unmount -b /dev/sdb1
Error unmounting /dev/sdb1: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error unmounting /dev/sdb1: Command-line `umount  "/run/media/ejs/UDISK 2.0"' exited with non-zero exit status 32: umount: /run/media/ejs/UDISK 2.0: not mounted

If I do "systemctl stop cups.service", udisksd does clean up the old directory (eventually, I mounted and unmounted another disk to trigger the cleanup).

Possibly related to bug #747114 or bug #808109 but this started with cups-1.5.3-2.fc17.
Comment 1 Jiri Popelka 2012-05-30 09:07:23 EDT
Thanks.

This could indeed be related to bug #747114, bug #808109.
Also the 1.5.3 provides an improved USB backend based on libusb 1.0,
which could possibly somehow interfere with this.
Do you have any printer configured on your system ?
Comment 2 Edward Sheldrake 2012-05-30 12:40:56 EDT
I have a USB Deskjet-5900-series (hplip) configured but it's not usually plugged in nor switched on.
Comment 3 Jiri Popelka 2012-05-31 11:45:05 EDT
I'm able to reproduce it even with cups-1.5.2-12.fc17.x86_64 so I'd say it's a duplicate of the above mentioned bugs. Let's wait for Tim (he was investigating them more deeply) to decide.
Comment 4 Tim Waugh 2012-09-19 04:52:53 EDT
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 747114 ***

Note You need to log in before you can comment on or make changes to this bug.