Bug 826529 - Upgrade from fedora 16->17 with preupgrade keeps using the fc16 kernel.
Upgrade from fedora 16->17 with preupgrade keeps using the fc16 kernel.
Status: CLOSED DUPLICATE of bug 826537
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 08:32 EDT by Martin Tilsted
Modified: 2012-05-30 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 14:54:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Tilsted 2012-05-30 08:32:53 EDT
I upgrade from Fedora16 to Fedora 17 with preupgrade, and anything worked except that the system did not update my /boot/grub2/grub.cfg file at all, so the system booted fedora 17 with the fedora 16 kernel. This does work except that the system does a kernel panic when shutting down.

My system is using raid1 on 2 disks but /boot is not using raid. Mount for /boot is:

/dev/sda2 on /boot type ext2 (rw,relatime,seclabel,user_xattr,acl,barrier=1)

And / (The only other filesystem I have) is mounted as

/dev/md0 on / type ext4 (rw,relatime,seclabel,user_xattr,acl,barrier=1,data=ordered)

A few more details available at http://superuser.com/questions/430293/fedora-17-keeps-using-fedora-16-kernel/430330#430330
Comment 1 Martin Tilsted 2012-05-30 08:34:43 EDT
Doing a grub2-mkconfig -o /boot/grub2/grub.cfg as root fixed the problem. So the system is now using the correct kernel.
Comment 2 Mads Kiilerich 2012-05-30 14:54:39 EDT

*** This bug has been marked as a duplicate of bug 826537 ***

Note You need to log in before you can comment on or make changes to this bug.