This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 826573 - [abrt] yum-utils-1.1.31-4.fc17: <string>:78:__init__:RuntimeError: cannot load dispatch table from pyexpat
[abrt] yum-utils-1.1.31-4.fc17: <string>:78:__init__:RuntimeError: cannot loa...
Status: CLOSED DUPLICATE of bug 814490
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:c85a2694fa5f973210a93009499...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 10:26 EDT by Daniel Scott
Modified: 2014-01-21 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 10:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Scott 2012-05-30 10:26:14 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/package-cleanup --orphans
comment:        Run package-cleanup --orphans
executable:     /usr/bin/package-cleanup
kernel:         3.3.7-1.fc16.x86_64
time:           Wed 30 May 2012 10:24:20 AM EDT
uid:            768
username:       djscott

smolt_data:     Text file, 9620 bytes

backtrace:
:<string>:78:__init__:RuntimeError: cannot load dispatch table from pyexpat
:
:Traceback (most recent call last):
:  File "/usr/bin/package-cleanup", line 400, in <module>
:    util = PackageCleanup()
:  File "/usr/bin/package-cleanup", line 60, in __init__
:    self.main()
:  File "/usr/bin/package-cleanup", line 362, in main
:    for po in sorted(self.doPackageLists(pkgnarrow='extras').extras):
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2686, in doPackageLists
:    avail = self.pkgSack.simplePkgList(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 167, in populate
:    if self._check_db_version(repo, mydbtype):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 225, in _check_db_version
:    return repo._check_db_version(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1272, in _check_db_version
:    repoXML = self.repoXML
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1466, in <lambda>
:    repoXML = property(fget=lambda self: self._getRepoXML(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1462, in _getRepoXML
:    self._loadRepoXML(text=self)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1453, in _loadRepoXML
:    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1428, in _groupLoadRepoXML
:    if self._commonLoadRepoXML(text):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1243, in _commonLoadRepoXML
:    result = self._getFileRepoXML(local, text)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1021, in _getFileRepoXML
:    size=102400) # setting max size as 100K
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 843, in _getFile
:    size=size
:  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 409, in urlgrab
:    return self._mirror_try(func, url, kw)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 395, in _mirror_try
:    return func_ref( *(fullurl,), **kwargs )
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1017, in urlgrab
:    return self._retry(opts, retryfunc, url, filename)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 918, in _retry
:    r = apply(func, (opts,) + args, {})
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1012, in retryfunc
:    apply(cb_func, (obj, )+cb_args, cb_kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1505, in _checkRepoXML
:    repoXML = repoMDObject.RepoMD(self.id, filepath)
:  File "/usr/lib/python2.7/site-packages/yum/repoMDObject.py", line 124, in __init__
:    self.parse(srcfile)
:  File "/usr/lib/python2.7/site-packages/yum/repoMDObject.py", line 140, in parse
:    parser = iterparse(infile)
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1188, in cElementTree_iterparse
:    return __cached_cElementTree.iterparse(filename)
:  File "<string>", line 78, in __init__
:RuntimeError: cannot load dispatch table from pyexpat
:
:Local variables in innermost frame:
:self: <iterparse object at 0x226bc50>
:b: <TreeBuilder object at 0x225d780>
:events: None
:file: <open file '/var/tmp/yum-djscott-n9w7kQ/x86_64/17/Dropbox/repomdQPVTRrtmp.xml', mode 'rt' at 0x2212a50>
Comment 1 Zdeněk Pavlas 2012-05-30 10:33:50 EDT

*** This bug has been marked as a duplicate of bug 814490 ***

Note You need to log in before you can comment on or make changes to this bug.