Bug 826589 - rpm --verify changed behaviour when verifying a package that is not installed
rpm --verify changed behaviour when verifying a package that is not installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm (Show other bugs)
7.0
All Unspecified
low Severity low
: rc
: ---
Assigned To: Panu Matilainen
Eduard Benes
: Regression, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 10:54 EDT by Patrik Kis
Modified: 2014-06-13 06:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.10.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:40:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2012-05-30 10:54:05 EDT
Description of problem:
When an uninstalled package is verified with yum the RHEL6 version reported all files as missing, while the RHEL7 version reports nothing and exit with 0.
It looks like an intention and the new behaviour quite make sense, but it changes the user experience.
Or is it a bug in RHEL6?

Version-Release number of selected component (if applicable):
rpm-4.9.1.3-7.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.0 Alpha1 (Maipo)
# rpm -q rpm
rpm-4.9.1.3-7.el7.x86_64
# 
# rpm -q zsh
package zsh is not installed
# rpm --verify -p zsh-4.3.17-1.el7.x86_64.rpm 
# echo $?
0
# 

  
Actual results:
the verify exit with 0

Expected results:
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
# rpm -q rpm
rpm-4.8.0-19.el6.x86_64
# 
# rpm -q zsh
package zsh is not installed
# rpm --verify -p zsh-4.3.10-4.1.el6.x86_64.rpm 
warning: zsh-4.3.10-4.1.el6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
missing     /bin/zsh
missing   c /etc/skel/.zshrc

<SNIP>

missing     /usr/share/zsh/site-functions
# echo $?
1
#
Comment 1 Panu Matilainen 2012-08-07 05:41:44 EDT
Good catch, thanks. This is actually an unintended change (ie in other words a regression) in rpm >= 4.9.x: verifying files against the original package can be sometimes useful. Fixed upstream now.
Comment 3 Panu Matilainen 2012-10-08 03:13:08 EDT
Fixed in rpm-4.10.1-1.el7.
Comment 5 Ludek Smid 2014-06-13 06:40:55 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.