Bug 826600 - kernel panic at shutdown
kernel panic at shutdown
Status: CLOSED DUPLICATE of bug 820351
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:10 EDT by Piotr Golonka
Modified: 2013-02-04 15:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 11:15:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Golonka 2012-05-30 11:10:49 EDT
Description of problem:

When trying to shut down the system, the machine gets to the text mode and the following is printed on the screen:

/shutdown: 33 /shutdown: sh not found
[ timestamp ] Kernel panic - not syncing: Attempt to kill init!
[ timestamp ] Pid: 1, comm: shutdown not tainted 3.3.7-1.fc16.x86_64 #1
[ timestamp ] Call Trace:
[ timestamp ] [addr] panic+0xba/0x1cd
[ timestamp ] [addr] do_exit+0x853/0x890
[ timestamp ] [addr] do_group_exit+0x42/0xa0
[ timestamp ] [addr] sys_exit_group+0x17/0x20
[ timestamp ] [addr] system_call_fastpath+0x16/0x1b
[ timestamp ] panic occured, switching back to text console

Version-Release number of selected component (if applicable):

Clean install of Fedora 17, KDE-Spin, installed to hard disk

How reproducible:
Shut down the system using the "K" menu on graphical session

Steps to Reproduce:
1.
2.
3.
  
Actual results:
machine hanging with kernel panic

Expected results:
shutdown of the machine

Additional info:
Comment 1 Josh Boyer 2012-05-30 11:15:27 EDT
(In reply to comment #0)
> Description of problem:
> 
> When trying to shut down the system, the machine gets to the text mode and
> the following is printed on the screen:
> 
> /shutdown: 33 /shutdown: sh not found
> [ timestamp ] Kernel panic - not syncing: Attempt to kill init!
> [ timestamp ] Pid: 1, comm: shutdown not tainted 3.3.7-1.fc16.x86_64 #1
> [ timestamp ] Call Trace:
> [ timestamp ] [addr] panic+0xba/0x1cd
> [ timestamp ] [addr] do_exit+0x853/0x890
> [ timestamp ] [addr] do_group_exit+0x42/0xa0
> [ timestamp ] [addr] sys_exit_group+0x17/0x20
> [ timestamp ] [addr] system_call_fastpath+0x16/0x1b
> [ timestamp ] panic occured, switching back to text console
> 
> Version-Release number of selected component (if applicable):
> 
> Clean install of Fedora 17, KDE-Spin, installed to hard disk

If this was a clean install, you wouldn't be using the F16 kernel which is what the oops above is from.

*** This bug has been marked as a duplicate of bug 820351 ***
Comment 2 Piotr Golonka 2012-05-30 11:39:11 EDT
This is in the system where I have two installations: F16 and F17 sharing the same /boot partition.
Indeed, there are F16 and F17 kernels there, and strange enough the kernel for F17 is actually *newer* than the one for F17...

Cannot upgrade the kernel for F17 for the time being, because the network interface was not detected (will submit another bug)
Comment 3 Piotr Golonka 2012-05-31 03:39:46 EDT
Hi there,
please have a look at #826866, which explains why the bad kernel was booted (likely a problem with grub2).

After correcting the grub.cfg and booting the proper F17 kernel everything went back to order and the problem is gone.

cheers,
 Piotr

Note You need to log in before you can comment on or make changes to this bug.