Bug 826601 - ncat does not write to output file with UDP
ncat does not write to output file with UDP
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nmap (Show other bugs)
6.3
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Hlavinka
Hubert Kario
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:11 EDT by Patrik Kis
Modified: 2013-05-30 11:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: nmap-5.51-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 11:49:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this (1011 bytes, patch)
2012-06-19 05:03 EDT, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description Patrik Kis 2012-05-30 11:11:10 EDT
Description of problem:
ncat does not write the session data to output file when the protocol is UDP

Version-Release number of selected component (if applicable):
nmap-5.51-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# ncat --udp --output ncatudp.log --listen 6666
TEST
^C
# ls -l ncatudp.log
-rw-r--r--. 1 root root 0 May 30 18:06 ncatudp.log

In this test the following command was used to send data to the server:
# echo TEST | ncat --udp localhost 6666
 
Actual results:
the output file is empty

Expected results:
# ncat --output ncattcp.log --listen 6666
TEST
^C
# cat ncattcp.log 
TEST
Comment 2 Michal Hlavinka 2012-06-05 06:20:35 EDT
reproducible in both rhel and latest fedora
Comment 4 Michal Hlavinka 2012-06-19 05:03:17 EDT
Created attachment 592879 [details]
patch to fix this
Comment 11 errata-xmlrpc 2013-05-30 11:49:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0881.html

Note You need to log in before you can comment on or make changes to this bug.