Bug 826621 - Unable to update fc17 after Upgrading from FC16 to FC17 using DVD_64 bits
Unable to update fc17 after Upgrading from FC16 to FC17 using DVD_64 bits
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:48 EDT by Majid
Modified: 2014-01-21 18:22 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 09:14:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Majid 2012-05-30 11:48:42 EDT
Description of problem:
I downloaded Fedora 17 and burned it on DVD then I upgrade from FC16 to FC17. Everything was fine. Then I wanted to update new FC17 using YUM Update command in command line as root that this problem happened. It downloads 396 MB but when tries to install this problem happens.
I copied and pasted the total error here: 
Additional info:

Total                                           142 kB/s | 229 MB     27:28     
Running Transaction Check
ERROR with transaction check vs depsolve:
libcups.so.2 is needed by gtk2-2.24.10-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 150 pre-existing rpmdb problem(s), 'yum check' output follows:
ConsoleKit-x11-0.4.5-1.fc15.x86_64 has missing requires of ConsoleKit = ('0', '0.4.5', '1.fc15')
GConf2-gtk-3.2.3-1.fc16.x86_64 has missing requires of GConf2 = ('0', '3.2.3', '1.fc16')
abrt-retrace-client-2.0.7-2.fc16.x86_64 has missing requires of abrt = ('0', '2.0.7', '2.fc16')
alsa-lib-1.0.25-3.fc17.x86_64 is a duplicate with alsa-lib-1.0.25-1.fc16.i686
alsa-plugins-pulseaudio-1.0.25-3.fc17.x86_64 is a duplicate with alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
atk-2.4.0-1.fc17.x86_64 is a duplicate with atk-2.2.0-2.fc16.i686
audit-libs-2.2.1-1.fc17.x86_64 is a duplicate with audit-libs-2.2.1-1.fc16.i686
avahi-libs-0.6.30-7.fc17.x86_64 is a duplicate with avahi-libs-0.6.30-4.fc16.i686
cairo-1.10.2-7.fc17.x86_64 is a duplicate with cairo-1.10.2-4.fc16.i686
caribou-antler-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
caribou-gtk2-module-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
caribou-gtk3-module-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
cracklib-python-2.8.18-2.fc15.x86_64 has missing requires of cracklib = ('0', '2.8.18', '2.fc15')
cyrus-sasl-lib-2.1.23-29.fc17.x86_64 is a duplicate with cyrus-sasl-lib-2.1.23-27.fc16.i686
db4-utils-4.8.30-3.fc15.x86_64 has missing requires of db4 = ('0', '4.8.30', '3.fc15')
1:dbus-libs-1.4.10-4.fc17.x86_64 is a duplicate with 1:dbus-libs-1.4.10-3.fc16.i686
expat-2.1.0-1.fc17.x86_64 is a duplicate with expat-2.1.0-1.fc16.i686
farsight2-python-0.0.31-1.fc16.x86_64 has missing requires of farsight2 = ('0', '0.0.31', '1.fc16')
farsight2-python-0.0.31-1.fc16.x86_64 has missing requires of libgstfarsight-0.10.so.0()(64bit)
flac-1.2.1-9.fc17.x86_64 is a duplicate with flac-1.2.1-8.fc16.i686
fontconfig-2.8.0-6.fc17.x86_64 is a duplicate with fontconfig-2.8.0-4.fc16.i686
freetype-2.4.8-3.fc17.x86_64 is a duplicate with freetype-2.4.6-5.fc16.i686
gamin-0.1.10-12.fc17.x86_64 is a duplicate with gamin-0.1.10-10.fc16.i686
gdk-pixbuf2-2.26.1-1.fc17.x86_64 is a duplicate with gdk-pixbuf2-2.24.1-1.fc16.i686
glib2-2.32.1-1.fc17.x86_64 is a duplicate with glib2-2.30.3-1.fc16.i686
glibc-2.14.90-24.fc16.6.i686 has missing requires of glibc-common = ('0', '2.14.90', '24.fc16.6')
glibc-2.15-37.fc17.x86_64 is a duplicate with glibc-2.14.90-24.fc16.6.i686
gnutls-2.12.17-1.fc17.x86_64 is a duplicate with gnutls-2.12.14-2.fc16.i686
gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 has missing requires of libcdio.so.12()(64bit)
gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
gtk2-2.24.8-3.fc16.i686 has missing requires of libcups.so.2
gtk2-2.24.10-1.fc17.x86_64 is a duplicate with gtk2-2.24.8-3.fc16.i686
ibus-hangul-1.4.1-2.fc16.x86_64 has missing requires of libibus-1.0.so.0()(64bit)
initscripts-legacy-9.34.2-1.fc16.x86_64 has missing requires of initscripts = ('0', '9.34.2', '1.fc16')
jasper-libs-1.900.1-19.fc17.x86_64 is a duplicate with jasper-libs-1.900.1-18.fc16.i686
keyutils-libs-1.5.5-2.fc17.x86_64 is a duplicate with keyutils-libs-1.5.2-1.fc16.i686
krb5-libs-1.10-5.fc17.x86_64 is a duplicate with krb5-libs-1.9.3-1.fc16.i686
libICE-1.0.8-1.fc17.x86_64 is a duplicate with libICE-1.0.7-1.fc16.i686
libSM-1.2.1-1.fc17.x86_64 is a duplicate with libSM-1.2.0-2.fc15.i686
libX11-1.4.3-1.fc16.i686 has missing requires of libX11-common = ('0', '1.4.3', '1.fc16')
libX11-1.4.99.901-2.fc17.x86_64 is a duplicate with libX11-1.4.3-1.fc16.i686
libXau-1.0.6-3.fc17.x86_64 is a duplicate with libXau-1.0.6-2.fc15.i686
libXcomposite-0.4.3-3.fc17.x86_64 is a duplicate with libXcomposite-0.4.3-2.fc15.i686
libXcursor-1.1.13-1.fc17.x86_64 is a duplicate with libXcursor-1.1.11-3.fc15.i686
libXdamage-1.1.3-3.fc17.x86_64 is a duplicate with libXdamage-1.1.3-2.fc15.i686
libXext-1.3.1-1.fc17.x86_64 is a duplicate with libXext-1.3.0-1.fc16.i686
libXfixes-5.0-2.fc17.x86_64 is a duplicate with libXfixes-5.0-1.fc16.i686
libXft-2.3.0-2.fc17.x86_64 is a duplicate with libXft-2.2.0-2.fc15.i686
libXi-1.6.1-1.fc17.x86_64 is a duplicate with libXi-1.4.5-1.fc16.i686
libXinerama-1.1.2-1.fc17.x86_64 is a duplicate with libXinerama-1.1.1-2.fc15.i686
libXrandr-1.3.1-3.fc17.x86_64 is a duplicate with libXrandr-1.3.1-2.fc15.i686
libXrender-0.9.7-1.fc17.x86_64 is a duplicate with libXrender-0.9.6-2.fc15.i686
libXt-1.1.2-2.fc17.x86_64 is a duplicate with libXt-1.1.1-1.fc16.i686
libXtst-1.2.0-3.fc17.x86_64 is a duplicate with libXtst-1.2.0-2.fc15.i686
libasyncns-0.8-3.fc17.x86_64 is a duplicate with libasyncns-0.8-2.fc15.i686
libcddb-1.3.2-7.fc16.x86_64 has missing requires of libcdio.so.12()(64bit)
libcddb-1.3.2-7.fc16.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
libcom_err-1.42-4.fc17.x86_64 is a duplicate with libcom_err-1.41.14-2.fc15.i686
libcurl-7.24.0-2.fc17.x86_64 is a duplicate with libcurl-7.21.7-7.fc16.i686
libdb-5.2.36-5.fc17.x86_64 is a duplicate with libdb-5.2.36-1.fc16.i686
libffi-3.0.10-2.fc17.x86_64 is a duplicate with libffi-3.0.10-1.fc16.i686
libgcc-4.7.0-5.fc17.x86_64 is a duplicate with libgcc-4.6.3-2.fc16.i686
libgcj-4.6.3-2.fc16.x86_64 has missing requires of libgmp.so.3()(64bit)
libgcrypt-1.5.0-3.fc17.x86_64 is a duplicate with libgcrypt-1.5.0-2.fc16.i686
libgpg-error-1.10-2.fc17.x86_64 is a duplicate with libgpg-error-1.10-1.fc16.i686
libidn-1.24-1.fc17.x86_64 is a duplicate with libidn-1.22-3.fc16.i686
libjpeg-turbo-1.2.0-1.fc17.x86_64 is a duplicate with libjpeg-turbo-1.2.0-1.fc16.i686
2:libogg-1.2.2-4.fc17.x86_64 is a duplicate with 2:libogg-1.2.2-3.fc15.i686
2:libpng-1.5.10-1.fc17.x86_64 is a duplicate with 2:libpng-1.2.49-1.fc16.i686
libproxy-python-0.4.7-1.fc16.noarch has missing requires of libproxy = ('0', '0.4.7', '1.fc16')
libreport-plugin-reportuploader-2.0.8-4.fc16.x86_64 has missing requires of libreport = ('0', '2.0.8', '4.fc16')
libselinux-2.1.10-3.fc17.x86_64 is a duplicate with libselinux-2.1.6-6.fc16.i686
libsndfile-1.0.25-2.fc17.x86_64 is a duplicate with libsndfile-1.0.25-1.fc16.i686
libssh2-1.4.1-2.fc17.x86_64 is a duplicate with libssh2-1.2.7-4.fc16.i686
libstdc++-4.7.0-5.fc17.x86_64 is a duplicate with libstdc++-4.6.3-2.fc16.i686
libtasn1-2.12-1.fc17.x86_64 is a duplicate with libtasn1-2.12-1.fc16.i686
libthai-0.1.14-5.fc17.x86_64 is a duplicate with libthai-0.1.14-4.fc15.i686
libtiff-3.9.5-3.fc17.x86_64 is a duplicate with libtiff-3.9.5-3.fc16.i686
libuuid-2.21.1-1.fc17.x86_64 is a duplicate with libuuid-2.20.1-2.3.fc16.i686
libv4l-0.8.7-1.fc17.x86_64 is a duplicate with libv4l-0.8.7-1.fc16.i686
1:libvorbis-1.3.3-1.fc17.x86_64 is a duplicate with 1:libvorbis-1.3.3-1.fc16.i686
libxcb-1.8-2.fc17.x86_64 is a duplicate with libxcb-1.7-3.fc16.i686
lyx-2.0.3-1.fc16.x86_64 has missing requires of libboost_regex-mt.so.1.47.0()(64bit)
lyx-2.0.3-1.fc16.x86_64 has missing requires of libboost_signals-mt.so.1.47.0()(64bit)
lyx-2.0.3-1.fc16.x86_64 has missing requires of lyx-fonts = ('0', '2.0.3', '1.fc16')
ncurses-libs-5.9-2.20110716.fc16.i686 has missing requires of ncurses-base = ('0', '5.9', '2.20110716.fc16')
ncurses-libs-5.9-4.20120204.fc17.x86_64 is a duplicate with ncurses-libs-5.9-2.20110716.fc16.i686
nspluginwrapper-1.4.4-7.fc17.x86_64 is a duplicate with nspluginwrapper-1.4.4-3.fc16.i686
nspr-4.9-2.fc17.x86_64 is a duplicate with nspr-4.9-2.fc16.i686
nss-3.13.4-3.fc17.x86_64 is a duplicate with nss-3.13.4-2.fc16.i686
nss-softokn-3.13.4-2.fc17.x86_64 is a duplicate with nss-softokn-3.13.4-1.fc16.i686
nss-softokn-freebl-3.13.4-2.fc17.x86_64 is a duplicate with nss-softokn-freebl-3.13.4-1.fc16.i686
nss-util-3.13.4-2.fc17.x86_64 is a duplicate with nss-util-3.13.4-2.fc16.i686
openldap-2.4.30-2.fc17.x86_64 is a duplicate with openldap-2.4.26-7.fc16.i686
1:openssl-1.0.0i-1.fc17.x86_64 is a duplicate with openssl-1.0.0i-1.fc16.i686
p11-kit-0.12-1.fc17.x86_64 is a duplicate with p11-kit-0.6-1.fc16.i686
pango-1.30.0-1.fc17.x86_64 is a duplicate with pango-1.29.4-1.fc16.i686
pidgin-2.10.2-1.fc16.x86_64 has missing requires of libgstfarsight-0.10.so.0()(64bit)
pidgin-2.10.2-1.fc16.x86_64 has missing requires of libpurple(x86-64) = ('0', '2.10.2', '1.fc16')
pixman-0.24.4-2.fc17.x86_64 is a duplicate with pixman-0.24.4-1.fc16.i686
pulseaudio-libs-1.1-9.fc17.x86_64 is a duplicate with pulseaudio-libs-0.9.23-1.fc16.i686
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of libpulsecommon-0.9.23.so()(64bit)
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of libpulsecore-0.9.23.so()(64bit)
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of pulseaudio = ('0', '0.9.23', '1.fc16')
pyclutter-1.3.2-2.fc15.x86_64 has missing requires of libclutter-glx-1.0.so.0()(64bit)
python-caribou-0.4.1-3.fc16.noarch has missing requires of caribou = ('0', '0.4.1', '3.fc16')
readline-6.2-4.fc17.x86_64 is a duplicate with readline-6.2-2.fc16.i686
sqlite-3.7.11-2.fc17.x86_64 is a duplicate with sqlite-3.7.7.1-1.fc16.i686
sssd-1.8.3-11.fc16.x86_64 has missing requires of libldb = ('0', '1.1.0', None)
tcp_wrappers-libs-7.6-69.fc17.x86_64 is a duplicate with tcp_wrappers-libs-7.6-64.fc16.i686
texlive-2007-66.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12()(64bit)
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libiso9660.so.7()(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12()(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libiso9660.so.7()(64bit)
2:vim-enhanced-7.3.515-1.fc16.x86_64 has missing requires of libruby.so.1.8()(64bit)
vlc-1.1.13-3.fc16.x86_64 has missing requires of libxcb-keysyms.so.1()(64bit)
vlc-core-1.1.13-3.fc16.x86_64 has missing requires of libcdio.so.12()(64bit)
vlc-core-1.1.13-3.fc16.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
vlc-core-1.1.13-3.fc16.x86_64 has missing requires of libiso9660.so.7()(64bit)
xcb-util-0.3.8-2.fc17.x86_64 is a duplicate with xcb-util-0.3.6-2.fc15.i686
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-acecad
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-aiptek
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-elographics
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-fpit
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-hyperpen
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-mutouch
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-penmount
xorg-x11-drv-apm-1.2.3-8.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-glint-1.2.5-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i128-1.3.4-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i740-1.3.2-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-nv-2.1.18-8.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-r128-6.8.1-11.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-savage-2.3.3-1.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sis-0.10.3-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-trident-1.3.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
zlib-1.2.5-6.fc17.x86_64 is a duplicate with zlib-1.2.5-6.fc16.i686
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-30.23-04.NLS7dk.yumtx
Comment 1 MikeP 2012-06-03 17:44:04 EDT
Hi

Had a very similar problem loads of broken dependency and duplicates

I accepted F17 is bleeding edge and so did the following:

package-cleanup --problems    this will be large but shows the problems

Then
#yum clean all
#yum clean packages
#yum clean headers
#yum clean oldheaders
#package-cleanup --cleandupes

#package-cleanup --problems

Remove obvious dupes still there by hand

#yum remove name of old package

#yum update

if this fails then repeat
#package-cleanup --problems

Remove obvious dupes still there by hand

#yum remove name of old package

Got there eventauly and probaly cleaned up loads of old stuff i got away with at the the f15 and F16 update :-)

the pureist would probaly say use yum to update not a DVD but with a BT drip feed internet that would be too painfull as any failure would be another 3 hour re-try for me

good luck
Comment 2 Majid 2012-06-04 23:22:01 EDT
Thank you for your fast response. I worked. I'm so grateful for your help.
Comment 3 Majid 2012-06-04 23:23:29 EDT
* I worked= It worked
Comment 4 MikeP 2012-06-05 07:31:58 EDT
Good stuff glad to be of help

mike
Comment 5 bob mckay 2012-07-04 21:42:50 EDT
I encountered similar problems, with hundreds of duplicate and orphan packages. What worked for me was:

yum --skip-broken distro-sync

(broke the back of the orphan and duplicate packages, reducing it down to 20 or so) followed by

package-cleanup --orphans > orphs
package-cleanup --dupes > dupes

then editing the orphs and dupes files by hand to construct 'yum remove' commands.

Some gotchas with this: 
.In the orphs list, you will get backup kernels and also any packages you installed by hand. You probably _don't_ want to remove these.
.Be very careful in editing the dupes list that you only remove the older package of each pair of duplicates. When you go to run the command, if you see lots of dependent packages listed to be removed, it almost certainly means that you are about to remove the _new_ version of the package. ABORT THE COMMAND and check again carefully.
Comment 6 bob mckay 2012-07-04 21:45:01 EDT
Oh, I forgot to mention that even

yum --skip-broken distro-sync

may abort with errors about specific packages (I hit these problems with some sane backends and cups libraries). To get it to work, I had to manually 'yum remove' those specific packages, remember them, go through the whole cleanup process, then manually reinstall.
Comment 7 Jan Zeleny 2013-05-22 09:14:05 EDT
> To get it to work, I had to manually
> 'yum remove' those specific packages, remember them, go through the whole
> cleanup process, then manually reinstall.

This is the right thing to do. Yum doesn't remove packages during the upgrade. Therefore if there are some packages that can't be updated for any reason and they are holding back the update of other packages, yum will fail to do the update altogether.

Note You need to log in before you can comment on or make changes to this bug.