Bug 826628 - Sync status remains in "error syncing" state even after successful sync of repo.
Sync status remains in "error syncing" state even after successful sync of repo.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: 6.0
Assigned To: Jason E. Rist
Hayk Hovsepyan
: Triaged, ZStream
Depends On: 753128 772350 784686
Blocks: katello-sync-mgmt
  Show dependency treegraph
 
Reported: 2012-05-30 12:02 EDT by Chris Pelland
Modified: 2014-09-18 11:36 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
UI sync status fails to update after changes are made. User has to check log files or use CLI to get accurate sync status. This update ensures that status updates to the sync management page are driven solely by data returned from the server.
Story Points: ---
Clone Of: 753128
Environment:
Last Closed: 2012-07-10 03:24:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 sachua 2012-06-07 02:25:37 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
UI sync status fails to update after changes are made. User has to check log files or use CLI to get accurate sync status. This update ensures that status updates to the sync management page are driven solely by data returned from the server.
Comment 2 Hayk Hovsepyan 2012-06-08 05:27:06 EDT
Verified on revision:

qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
pulp-selinux-server-1.0.4-1.el6.noarch
katello-selinux-0.1.10-1.el6.noarch
katello-all-0.1.313-1.el6_3.noarch
katello-cli-common-0.1.108-1.el6_3.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-foreman-0.1.313-1.el6_3.noarch
katello-configure-0.1.109-1.el6_3.noarch
katello-qpid-client-key-pair-1.0-1.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-qpid-0.14-7.el6_2.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
katello-cli-0.1.108-1.el6_3.noarch
pulp-common-1.0.4-1.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-candlepin-0.1.313-1.el6_3.noarch
katello-0.1.313-1.el6_3.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.0.7-1.el6_3.noarch
candlepin-0.6.5-1.el6_2.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.0.4-1.el6.noarch
katello-common-0.1.313-1.el6_3.noarch
katello-glue-pulp-0.1.313-1.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64

Steps do duplicate:

1. Create repo with wrong URL. (before create custom provider and product)
2. Sync repo from Sync Management > Sync Status.
3. Verify that "Error Syncing" is displayed.
4. Remove created repo.
5. Add new repo with the same name but with correct URL.
6. Sync repo.
7. Verify that "Sync complete." is displayed.

The same steps could be done by CLI as well, and it works fine.
Comment 4 errata-xmlrpc 2012-07-10 03:24:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html
Comment 5 Mike McCune 2013-08-16 14:02:15 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.