Bug 82663 - USRobotics card doesn't work, says "please report"
USRobotics card doesn't work, says "please report"
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-24 12:55 EST by Johannes Teveßen
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:21:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Teveßen 2003-01-24 12:55:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
This is a "USR022410" (U.S.Robotics) 11Mbit/s WLAN card,
which is not or wrongly recognized by RedHat 8.0 when
used as PCMCIA.

The card ships with a PCI adapter (which is not really
a PCMCIA<->PCI bridge, but a PLX card) and works fine
when using the PCI interface and using the "prism2_plx.o"
kernel module.

However, when using *just* the PCMCIA card on RH80,
which should be a very straight PrismII chipset,
wvlan_cs is loaded and reports:

  kernel: NETDEV WATCHDOG: eth0: transmit timed out
  kernel: wvlan_cs: eth0 Tx timed out! Resetting card
  kernel: wvlan_cs: MAC address on eth0 is 00 90 d1 06 66 fd
  kernel: wvlan_cs: Unrecognised card, card return vendor = 0x0003, please report...
  kernel: wvlan_cs: Found firmware 0x8 (vendor 3) - Firmware capabilities :
0-0-0-0-0
  kernel: wvlan_cs: This firmware doesn't support ``port_type=3'', please use
iwconfig.
  kernel: wvlan_cs: Initialization failed!

which I find rather strange. These messages repeat every
few seconds as long as the card is inserted.

"port_type=3" means Ad-Hoc and is nothing I configured
(although I want it to run in Ad-Hoc mode).

Please remember that this card works fine when in PCI
mode. I'm puzzled about why its vendor isn't recognized.
I bought this USR card more than half a year ago.

If you happen to need further information, don't
hesitate to contact me. Many thanks.

The very same laptop (Compaq Armada M700) works fine
if I replace this card by a Compaq WLAN card.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert card
2. Watch the kernel/PCMCIA-WLAN messages
3. fails.
    

Actual Results:  Failure to detect the card. eth0 (or wlan0) show up,
but aren't configureable in any way (iwconfig eth0
essid SOMESTRING fails after about two seconds and
the same error is printed again in the logfiles).


Expected Results:  Card should work, because it's a pretty straight-forward
PrismII and works with PCI adapter and prism2_plx


Additional info:
Comment 1 Bill Nottingham 2003-01-24 13:01:10 EST
We don't ship a prism2_plx driver...

What happens if you use orinoco_cs?

What does 'cardctl ident' say with it plugged in?
Comment 2 Johannes Teveßen 2003-01-24 13:23:34 EST
whew - that was a _really_ fast response. :-)

Yes, I know, the "prism2_plx.o" which I use on the box
that I use this card as PCI on is seperately shipped
within "linux-wlan-ng-0.1.16-pre8.tar.gz" and works fine
(only with PCI; I'm troubled with installing it on the
vanilla RH80 kernel because of MODVERSIONs and stuff).

Give me a second, I'll look up the requested information
(I'll have to remove Ethernet for the moment..)

1) I don't know how to use orinoco_cs when the RH pcmcia
   scripts try to load the other driver(s).
   Without knowing what I'm doing, I just tried to rmmod
   wvlan_cs and modprobe orinoco_cs, but nothing happens
   (no eth0, no wlan0).

2) "cardctl ident" says:
  Socket 0:
    product info: "U.S. Robotics", "IEEE 802.11b PC-CARD", "Version 01.02", ""
    manfid: 0x0156, 0x0002
    function: 6 (network)
  Socket 1:
    no product info available

This is the latest kernel 2.4.18-19.8.0 with sources installed.

cardmgr now reports in the logfile:

Jan 24 19:08:29 localhost cardmgr[596]: socket 0: Intersil PRISM2 Reference
Design 11Mb/s WLAN Card
Jan 24 19:08:29 localhost cardmgr[596]: executing: 'modprobe prism2_cs'
Jan 24 19:08:29 localhost cardmgr[596]: + modprobe: Can't locate module prism2_cs
Jan 24 19:08:29 localhost cardmgr[596]: modprobe exited with status 255
Jan 24 19:08:29 localhost cardmgr[596]: module
/lib/modules/2.4.18-19.8.0/pcmcia/prism2_cs.o not available
Jan 24 19:08:30 localhost cardmgr[596]: get dev info on socket 0 failed:
Resource temporarily unavailable

which I haven't seen before (maybe because of the orinoco module?).

I don't know why it tries to load the prism2_cs module now,
since this is only available within my freshly installed
vanilla 2.4.20 kernel, which is not currently running:

# locate prism2_cs
/home/johnny/down/wlan/linux-wlan-ng-0.1.16-pre8/src/prism2/driver/prism2_cs.o
/lib/modules/2.4.20/pcmcia/prism2_cs.o
# uname -a
Linux localhost.localdomain 2.4.18-19.8.0 #1 Thu Dec 12 05:39:29 EST 2002 i686
i686 i386 GNU/Linux

2.4.20 and linux-wlan-ng are on the harddisk since yesterday.
It didn't work with the vanilla RedHat kernel and modules
before, too.

I'm happy about having to load modules on my own, but
neither the RedHat-shipped nor the post-installed modules
from linux-wlan-ng seem to work by now. The logfile messages
I quoted for you are from a vanilla RH80 system (2.4.18-19.8.0);
so I wonder why this prismII isn't supported out-of-the-box.
Maybe a problem with wvlan_cs detecting the vendor?

Thanks for any help.

(switching back to Xircom Ethernet/Modem/ISDN. PCMCIA is *so*
really nice for hotplug. :->>)
Comment 3 Johannes Teveßen 2003-01-24 13:27:35 EST
Re-reading my submission, I just realized that it might
be possible that the RH scripts in /etc/pcmcia (which
I backuped before) have been overwritten by linux-wlan-ng;
however, it didn't work before, too, and the new scripts
already seem to recognize the card to be "PrismII Reference
Design", so it should be pretty easy to get it working,
in theory.

It still doesn't work with the RH modules and scripts,
and I'm wondering why. If even a reference design
doesn't work, I mean.
Comment 4 Bill Nottingham 2003-01-24 15:48:27 EST
Basically, to try orinoco_cs, find something that looks like:

card "Intersil PRISM2 11 Mbps Wireless Adapter"
  manfid 0x0156, 0x0002
  bind "<something>"

and change <something> to orinoco_cs.

Then restart pcmcia.

Note You need to log in before you can comment on or make changes to this bug.