Bug 826638 - apg postinstall scriptlet appends duplicate entry to services
apg postinstall scriptlet appends duplicate entry to services
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apg (Show other bugs)
17
All All
unspecified Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 12:28 EDT by Peter Backes
Modified: 2012-06-08 20:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 20:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Backes 2012-05-30 12:28:31 EDT
Description of problem:
after installing apg, a duplicate entry for pwdgen is appended to /etc/services

Version-Release number of selected component (if applicable):
setup-2.8.48-1.fc17.noarch
apg-2.3.0b-13.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. install apg
  
Actual results:
/etc/services has the line
pwdgen          129/tcp                 # PWDGEN service
despite the fact that it always contains one.

Expected results:
no such line has been appended

Additional info:
This seems to be caused by a typo in the scriptlet, it does /bin/grep ^pwgen /etc/services, where pwgen should be pwdgen (missing "d")
Comment 1 Kevin Fenzi 2012-05-30 14:35:16 EDT
Oops. Quite right. Will fix up... sorry for the trouble.
Comment 2 Fedora Update System 2012-05-30 14:49:43 EDT
apg-2.3.0b-15.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/apg-2.3.0b-15.fc17
Comment 3 Fedora Update System 2012-06-01 13:13:18 EDT
Package apg-2.3.0b-15.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apg-2.3.0b-15.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8738/apg-2.3.0b-15.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-06-05 19:03:41 EDT
Package apg-2.3.0b-16.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apg-2.3.0b-16.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8738/apg-2.3.0b-16.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-08 20:00:49 EDT
apg-2.3.0b-16.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.