Bug 826676 - FC17 netstat does not report SCTP associations properly
FC17 netstat does not report SCTP associations properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 14:21 EDT by Peter Butler
Modified: 2012-08-13 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 20:51:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Butler 2012-05-30 14:21:53 EDT
Description of problem:

netstat outputs the following error, once per client association address:

SCTP error in line: <address line num>

rather than the actual output, which can still be found in /proc/net/sctp/assocs

See below for a specific example.

NOTE: this was working properly in FC16




Version-Release number of selected component (if applicable):

FC17 3.3.4-5 x86_64


How reproducible:

100%



Steps to Reproduce:
1. Create a server listening on an SCTP (IPv4) socket
2. Connect from a client to the server on an SCTP (IPv4) socket
3. run "netstat --sctp" and notice that the association info (which can be found in /proc/net/sctp/assocs) results in errors from netstat
  


Actual results:

netstat generates "SCTP error in line: <address line num>" errors - one per line of association info (i.e. per address)



Expected results:

A human-readable interpretation of the data in /proc


Additional info:

This issue appears to have been introduced with FC17 as it was working 
properly with FC16.

Basically, when listing SCTP associations via netstat (i.e. "netstat 
--sctp"), an error is displayed (see below).  Servers appear to be listed 
without issue - although that could just be due to the specific parameters 
of my application.  In any case, the servers and associations appear to be 
listed properly in /proc/net/sctp/eps and /proc/net/sctp/assocs, so 
presumably (?) the issue is just with netstat's interpretation of the data 
in /proc.

Example:

After starting an SCTP server:

the netstat output is correct:

[peter@peter ~]$ netstat -nap --sctp
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.) 
Active Internet connections (servers and established) 
Proto Recv-Q Send-Q Local Address           Foreign Address         State  
    PID/Program name 
sctp       0      0 10.91.20.100:4105       0.0.0.0:*               LISTEN 
     1602/server


and it matches that in /proc:

[peter@peter ~]$ cat /proc/net/sctp/eps 
 ENDPT     SOCK   STY SST HBKT LPORT   UID INODE LADDRS 
ffff880222fdac00 ffff880221d504c0 2   10  9    4105   1000 27667 
10.91.20.100 10.91.10.100 
 
[peter@peter ~]$ cat /proc/net/sctp/assocs 
 ASSOC     SOCK   STY SST ST HBKT ASSOC-ID TX_QUEUE RX_QUEUE UID INODE 
LPORT RPORT LADDRS <-> RADDRS HBINT INS OUTS MAXRT T1X T2X RTXC



Whereas after an association is established by a client:

the netstat output reports an error where the two client lines would 
normally be output (2 lines due to 2 addresses on client side of 
association):

[peter@peter ~]$ netstat -nap --sctp
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State  
    PID/Program name
sctp       0      0 10.91.20.100:4105       0.0.0.0:*               LISTEN 
     1602/server
SCTP error in line: 1
SCTP error in line: 2


the server entry matches that in /proc:

[peter@peter ~]$ cat /proc/net/sctp/eps
 ENDPT     SOCK   STY SST HBKT LPORT   UID INODE LADDRS
ffff880222fdac00 ffff880221d504c0 2   10  9    4105   1000 27667 
10.91.20.100 10.91.10.100


and the client entries are also reported in /proc (even though they yielded the aforementioned errors when using netstat):

[peter@peter ~]$ cat /proc/net/sctp/assocs
 ASSOC     SOCK   STY SST ST HBKT ASSOC-ID TX_QUEUE RX_QUEUE UID INODE 
LPORT RPORT LADDRS <-> RADDRS HBINT INS OUTS MAXRT T1X T2X RTXC
ffff880223e51000 ffff880222fd0000 2   1   3  6426    8        0        0  
1000 10777 4105   4106  10.91.20.100 10.91.10.100 <-> *10.91.0.100   30000 
   10    10    1    0    0        0
ffff880223e56800 ffff880221d50980 2   1   3  6681    7        0        0  
1000 27692 4106   4105  10.91.0.100 <-> *10.91.20.100 10.91.10.100   30000 
   10    10 59885    0    0        0
Comment 1 Jiri Popelka 2012-06-20 03:25:58 EDT
Could you try this build ?
http://koji.fedoraproject.org/koji/taskinfo?taskID=4177731
Comment 2 Peter Butler 2012-06-20 13:43:52 EDT
Works now!

[peter@peter ~]$ netstat -nap --sctp
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
sctp                10.91.20.100:4105                               LISTEN
                    10.91.10.100:4105                                           9841/./server
sctp       0      0 10.91.20.100:4105       10.91.0.100:4106        ESTABLISHED
                    10.91.10.100                                                9841/./server
sctp       0      0 10.91.0.100:4106        10.91.20.100:4105       ESTABLISHED
                                            10.91.10.100                        9849/./client
Comment 3 Fedora Update System 2012-07-31 10:40:43 EDT
net-tools-1.60-138.20120702git.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/net-tools-1.60-138.20120702git.fc17
Comment 4 Fedora Update System 2012-08-01 14:30:14 EDT
Package net-tools-1.60-138.20120702git.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing net-tools-1.60-138.20120702git.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11345/net-tools-1.60-138.20120702git.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-13 20:51:33 EDT
net-tools-1.60-138.20120702git.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.