Bug 826701 - Review Request: hibernate-tools - Hibernate tools
Review Request: hibernate-tools - Hibernate tools
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
NotReady
:
Depends On: 828223
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 15:45 EDT by gil cattaneo
Modified: 2015-10-21 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 12:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gil cattaneo 2012-05-30 15:45:22 EDT
Spec URL: http://gil.fedorapeople.org/hibernate-tools.spec
SRPM URL: http://gil.fedorapeople.org/hibernate-tools-3.2.4-1.fc16.src.rpm
Description: Forward- and reverse-engineering tools for Eclipse and Ant.
Fedora Account System Username: gil
Comment 1 Marek Goldmann 2012-06-04 04:27:58 EDT
The proper upstream URL for source is: https://github.com/hibernate/hibernate-tools

Which part of Hibernate 4 requires this library?
Comment 4 Marek Goldmann 2012-06-04 09:58:53 EDT
What's the reason to go to alpha?
Comment 5 Marek Goldmann 2012-06-04 09:59:43 EDT
Ah, ok, the repo is missing tags.
Comment 7 Marek Goldmann 2012-08-13 08:45:01 EDT
Some information about versioning of Hibernate Tools.

Old SVN repository should not be used.

On GitHub there are 3 branches:

- 3.4.x - supoprt for hibernate-core 3.3-3.5
- 3.6.x - support for hibernate-core 3.6
- master - support for hibernate-core 4

These 3 versions have different API's and most probably we'll need to package two or all of them.

There are no tags at this moment, it should be fixed in the future.

Some more info about why we need to have available multiple versions of these libraries. Since we have hibernate3 package and hibernate (4) in plans I thought about having two packages available in Fedora:

1. 3.6.x (hibernate-tools36 package) branch and
2. master (hibernate-tools package) branch

But it seems that the 3.4.x branch also needs to be packaged, because the some main code in Hibernate Tools requires it and we would end up in some incompatibility issues:

12:32 <@maxandersen> mgoldmann: when you create a project in eclipse it has some 
                     metadata in the .settings folder.
12:33 <@maxandersen> mgoldmann: if you share this with another team member (you 
                     often do to avoid reconfigure projects) they will not 
                     load/behave differently.
12:33 <@maxandersen> mgoldmann: and if you don't do that - there is the mechanism 
                     that uses mvn to let its pom.xml configure your project based 
                     on pom.xml and this would also be a bit funky if 3.5 is 
                     "nothere"

(there is a typo above and 3.5 should be read 3.4)

If this package is not immediately needed, I would postpone it and get back to it once it'll be a hard stop for someone. In the meantime we can find a solution to satisfy all requirements. If any.
Comment 9 Mikolaj Izdebski 2015-02-12 00:12:18 EST
Package is marked as not ready. Is this intentional? If so, can we remove block on FE-JAVASIG?
Comment 10 gil cattaneo 2015-02-12 00:36:52 EST
(In reply to Mikolaj Izdebski from comment #9)
> Package is marked as not ready. Is this intentional?
should ask to Marek before ...
 If so, can we remove
> block on FE-JAVASIG?
yes sure, thanks!
Comment 11 Mikolaj Izdebski 2015-02-12 00:38:18 EST
OK, I've removed block on FE-JAVASIG. Feel free to re-add it once package is ready.
Comment 12 gil cattaneo 2015-10-21 12:47:46 EDT
No more interested to maintains this package

Note You need to log in before you can comment on or make changes to this bug.