Bug 826708 - Audrey agent fails to connect to config server openssl self signed cert issue
Audrey agent fails to connect to config server openssl self signed cert issue
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-audrey-agent (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: 1.0.1
: ---
Assigned To: Dan Radez
dgao
: Rebase, Triaged, ZStream
Depends On: 812915
Blocks: 813319
  Show dependency treegraph
 
Reported: 2012-05-30 16:02 EDT by Chris Pelland
Modified: 2012-07-10 03:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Audrey 0.4.8 experienced certification problems using httplib2 0.7.x. This causes runtime configuration failure with instances. An update for Audrey 0.4.9 adds compatibility with httplib2 0.7.x and provides successful runtime configuration.
Story Points: ---
Clone Of: 812915
Environment:
Last Closed: 2012-07-10 03:23:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Dan Macpherson 2012-06-06 21:25:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Audrey 0.4.8 experienced certification problems using httplib2 0.7.x. This causes runtime configuration failure with instances. An update for Audrey 0.4.9 adds compatibility with httplib2 0.7.x and provides successful runtime configuration.
Comment 3 dgao 2012-06-13 13:29:30 EDT
[root@10-16-120-177 ~]# cat /var/log/audrey.log 
2012-06-13 13:26:44,423 - INFO    : audrey:1305 Invoked audrey_script_main
2012-06-13 13:26:44,685 - INFO    : audrey:1334 
<Instance of: CSClient
	Version: 1
	Config Server Endpoint: https://deaddonkey.usersys.redhat.com
	Config Server oAuth Key: af6caa10-b56d-11e1-9376-e83935c21f2c
	Config Server oAuth Secret: dNq4bvMxPoKwr3tFuChikdIe5nQYCRuqejSSKuzIOzT2
	Config Server Params: 
	Config Server Configs: 
	Temporary Directory: 
	Tarball Name: 
eot>
2012-06-13 13:26:44,686 - INFO    : audrey:951 Invoked CSClient.get_cs_tooling()
2012-06-13 13:26:44,886 - INFO    : audrey:683 Invoked unpack_tooling()
2012-06-13 13:26:44,888 - INFO    : audrey:908 Invoked CSClient.get_cs_configs()
2012-06-13 13:26:45,086 - INFO    : audrey:923 Invoked CSClient.get_cs_params()
2012-06-13 13:26:45,286 - INFO    : audrey:521 Invoked generate_provides()
2012-06-13 13:26:45,636 - INFO    : audrey:938 Invoked CSClient.put_cs_params_values()
[root@10-16-120-177 ~]# rpm -qa | grep "python-httplib"
python-httplib2-0.7.4-1.el6.noarch
[root@10-16-120-177 ~]# rpm -qa | grep "audrey"
aeolus-audrey-agent-0.4.9-1.el6_2.noarch
Comment 5 errata-xmlrpc 2012-07-10 03:23:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.