Bug 826717 - Changeset Fails to Promote with Candlepin RPM
Changeset Fails to Promote with Candlepin RPM
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Kedar Bidarkar
: Triaged, ZStream
Depends On: 818370
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 16:21 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In templates, System Engine incorrectly parsed RPMs names with dashes and dots. This cause changeset promotion to fail. This update modifies the regular expression to parse the PRM name. System Engine correctly parses the PRM name and provides successful changeset promotion.
Story Points: ---
Clone Of: 818370
Environment:
Last Closed: 2012-07-10 03:24:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Petr Chalupa 2012-05-31 06:12:29 EDT
fixed by inecas in commit 3359586c68ba55f7607b9db5f01577d4fca78acf
Comment 3 Mike McCune 2012-06-13 01:29:03 EDT
FYI this effects all rpms with hypens in the package name, the candlepin RPM was just an example
Comment 4 Ivan Necas 2012-06-13 03:31:42 EDT
Just a note: dots in name were the main issue here: names like "pakcage-example.com-1.0-1.noarch" were causing it. Packages with hyphens only were fine before
Comment 5 Kedar Bidarkar 2012-06-14 06:37:17 EDT
Created a template which had our 
a) custom RHEL distro from 'RHEL' provider 
b) custom candlepin repo from 'candlepin' Provider

Created changeset containing 

a) RHEL product, 
b)candlepin repo, and
c) the above system template. 

The promotion was successful.

Will be attaching shortly the template downloaded from the Dev env , after promotion of changeset was successful.
Comment 7 Dan Macpherson 2012-06-17 19:13:53 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In templates, System Engine incorrectly parsed RPMs names with dashes and dots. This cause changeset promotion to fail. This update modifies the regular expression to parse the PRM name. System Engine correctly parses the PRM name and provides successful changeset promotion.
Comment 9 errata-xmlrpc 2012-07-10 03:24:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html
Comment 10 Mike McCune 2013-08-16 14:02:06 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.