Bug 826723 - Failed to load spotify public key
Failed to load spotify public key
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clementine (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 16:36 EDT by Matthew Davis
Modified: 2012-06-25 20:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:34:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2012-05-30 16:36:11 EDT
Description of problem:

When I goto the Spotify section in the prefs, and click 'download' I get the error "Failed to load Spotify public key" And I get these errors in the console:

16:28:40.269 INFO  SpotifyBlobDownloader:76         Downloading  QUrl( "http://spotify.clementine-player.org/version11-64bit/blob" )  
16:28:40.270 INFO  SpotifyBlobDownloader:76         Downloading  QUrl( "http://spotify.clementine-player.org/version11-64bit/blob.sha1" )  
16:28:40.271 INFO  SpotifyBlobDownloader:76         Downloading  QUrl( "http://spotify.clementine-player.org/version11-64bit/libspotify.so.10.1.16" )  
16:28:40.271 INFO  SpotifyBlobDownloader:76         Downloading  QUrl( "http://spotify.clementine-player.org/version11-64bit/libspotify.so.10.1.16.sha1" )  
16:28:40.755 WARN  SpotifyBlobDownloader:213        "Failed to load Spotify public key" 


Version-Release number of selected component (if applicable):
clementine-1.0.1-4.fc17.x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1. Install clementine
2. Goto prefs
3. Goto spotify
4. Click download
  
Actual results:
Error

Expected results:
Success


It seems to be fixed in upstream according to the google bug here:
http://code.google.com/p/clementine-player/issues/detail?id=2758
Comment 1 Fedora Update System 2012-06-05 23:19:52 EDT
clementine-1.0.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/clementine-1.0.1-6.fc17
Comment 2 Fedora Update System 2012-06-07 18:56:53 EDT
Package clementine-1.0.1-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clementine-1.0.1-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9019/clementine-1.0.1-6.fc16
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-06-25 20:34:33 EDT
clementine-1.0.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2012-06-25 20:42:18 EDT
clementine-1.0.1-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.