This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 826729 - My Installed Software Tab - Move Cert Status up to top of Product's Subscription Details
My Installed Software Tab - Move Cert Status up to top of Product's Subscript...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-30 16:41 EDT by Matt Reid
Modified: 2013-01-07 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Default Sizing of Sub-man-gui, no cert status visible (51.20 KB, image/png)
2012-06-08 10:56 EDT, Matt Reid
no flags Details
Cert status (126.92 KB, image/png)
2012-08-10 02:51 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Matt Reid 2012-05-30 16:41:39 EDT
Description of problem:
The Product's Subscription Details pane in My Installed Software often gets squished when the window size isn't very large. I feel like Cert Status is the most important thing in the pane, as it is the most likely to change, and is the least likely to show right now without scrolling. Can we shift it to the top of the pane, and push everything else down one item?
Comment 1 Bryan Kearney 2012-06-07 17:07:57 EDT
This one seems odd. if I am looking at products, i would assume product data would be first.
Comment 2 Matt Reid 2012-06-08 10:56:43 EDT
Created attachment 590457 [details]
Default Sizing of Sub-man-gui, no cert status visible
Comment 3 Matt Reid 2012-06-08 11:07:10 EDT
Product data is only half new though, we currently immediately list product name, which is already listed in full in the table, and then product id, which is new information (but feels less useful to me than cert status). I can see your argument, but I feel like we need to increase the visibility of cert status somehow, as that's actually expanding on info we show in the table. If there's an issue with that product, they may have to click on the product, and then scroll (or adjust window size) before they can see the detailed information on what the issue is. If cert status was listed earlier, they would see it in the details pane without adjusting anything.

Would you rather we just flip flop Subscription and Cert Status? Listing it 3rd should still make it visible.
Comment 4 Alex Wood 2012-08-09 10:56:19 EDT
commit 79f4c44117220086fbdf9b601e6403336d7f183a
Refs: <origin/wottop/826729>, subscription-manager-1.0.11-1-5-g79f4c44
Author:     William Poteat <wpoteat@redhat.com>
AuthorDate: Mon Jul 30 15:58:24 2012 -0400
Commit:     William Poteat <wpoteat@redhat.com>
CommitDate: Mon Jul 30 16:15:07 2012 -0400

    826729: Move Cert Status up to top of Product's Subscription Details
Comment 5 RHEL Product and Program Management 2012-08-09 10:57:17 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 Shwetha Kallesh 2012-08-10 02:51:43 EDT
Created attachment 603432 [details]
Cert status

Verified!!

[root@dhcp201-115 pki]# rpm -qa | grep subscription-manager
subscription-manager-1.0.13-1.git.14.28f8917.el5
subscription-manager-firstboot-1.0.13-1.git.14.28f8917.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-migration-1.0.13-1.git.14.28f8917.el5
subscription-manager-gui-1.0.13-1.git.14.28f8917.el5
Comment 9 errata-xmlrpc 2013-01-07 22:53:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.