Bug 826745 - Undefined non-weak symbols
Undefined non-weak symbols
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreport (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: abrt
Iveta Wiedermann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 17:24 EDT by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
8 users (show)

See Also:
Fixed In Version: libreport-2.0.9-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:53:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-05-30 17:24:16 EDT
`prelink -avMR' shows the following warning:


Prelinking /usr/lib64/libabrt_web.so.0.0.1
prelink: Warning: /usr/lib64/libabrt_web.so.0 has undefined non-weak symbols


libreport-2.0.9-5.el6.x86_64
Comment 1 Nikola Pajkovsky 2012-05-31 08:35:31 EDT
Jiri take that one

commit 27257a32c88c404a5e13521d38742bd5a8a7d955
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Tue May 15 15:09:32 2012 +0200

    prelink: fix undefined non-weak symbols
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 4 Nikola Pajkovsky 2013-01-08 09:42:15 EST
abrt also needs following patch

commit 6c96fe597fb578f59efc36e39487dbbfc6f9e4b6
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Tue May 15 13:27:08 2012 +0200

    libabrt: link with libreport
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>

fully resolve prelinks weak-symobls
Comment 6 Jiri Moskovcak 2013-01-24 09:59:21 EST
Cause
    Wrong linker parameters
Consequence
    Errors when running prelink on the affected libraries
Fix
    Add the proper linker flags
Result
    No errors when running prelink on abrt libreries
Comment 7 errata-xmlrpc 2013-02-21 02:53:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html

Note You need to log in before you can comment on or make changes to this bug.