Bug 826800 - ABRT unable to generate backtrace properly unless run as root user
ABRT unable to generate backtrace properly unless run as root user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 21:38 EDT by Ryan
Modified: 2012-08-29 20:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 20:56:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan 2012-05-30 21:38:42 EDT
Description of problem:

When running abrt, it requires root privelidges to gather information, if not given it can't generate the bug report properly. When opening ABRT, there is no prompt for root credentials, which there should be as it's a requirement

Version-Release number of selected component (if applicable):

ABRT-2.1.0

How reproducible:

very reproducable

Steps to Reproduce:
run Abrt-gui as standard user and attempt to generate a backtrace on a bug, this fails as it cannot gather enough information
  
Actual results:

backtrace generation fails

Expected results:

no failure
Comment 1 Jiri Moskovcak 2012-06-15 04:50:02 EDT
Are you trying to generate a backtrace for a crash which happens in a program running with root privs?
Comment 2 Jiri Moskovcak 2012-06-15 04:54:52 EDT
Sounds like a dupe of #830389
Comment 3 Ryan 2012-06-17 21:55:13 EDT
I will need to investigate further, most of the time they are bugs that come up at boot, and mostly appear to be from services
Comment 4 Denys Vlasenko 2012-06-19 07:49:29 EDT
(In reply to comment #0)
> Steps to Reproduce:
> run Abrt-gui as standard user and attempt to generate a backtrace on a bug,
> this fails as it cannot gather enough information
>   
> Actual results:
> 
> backtrace generation fails

How it fails?
Please sshow the log messages.
Comment 5 Denys Vlasenko 2012-06-19 08:21:40 EDT
Possibly an effect of fork_execv_on_steroids(uid=0) on "stolen" root crash.
Possible solution is to stop changing uid.
Comment 6 Denys Vlasenko 2012-06-25 06:22:17 EDT
Hopefully fixed by this commit:

commit 1ca0fd4e0086991b80856e77eed32f1bd812e5d8
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Mon Jun 25 12:20:14 2012 +0200

    Don't setuid/setgid when we run eu-unstrip and gdb
Comment 7 Fedora Update System 2012-08-03 06:27:09 EDT
abrt-2.0.11-1.fc17,libreport-2.0.11-1.fc17,btparser-0.18-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.11-1.fc17,libreport-2.0.11-1.fc17,btparser-0.18-2.fc17
Comment 8 Fedora Update System 2012-08-05 17:34:13 EDT
Package abrt-2.0.11-1.fc17, btparser-0.18-2.fc17, libreport-2.0.12-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.11-1.fc17 btparser-0.18-2.fc17 libreport-2.0.12-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.11-1.fc17,libreport-2.0.12-1.fc17,btparser-0.18-2.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-08-09 19:09:28 EDT
Package libreport-2.0.12-2.fc17, abrt-2.0.11-1.fc17, btparser-0.18-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.0.12-2.fc17 abrt-2.0.11-1.fc17 btparser-0.18-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.11-1.fc17,libreport-2.0.12-2.fc17,btparser-0.18-2.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-23 19:27:57 EDT
Package abrt-2.0.12-1.fc17, libreport-2.0.13-1.fc17, btparser-0.18-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.12-1.fc17 libreport-2.0.13-1.fc17 btparser-0.18-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.12-1.fc17,libreport-2.0.13-1.fc17,btparser-0.18-2.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-08-29 20:56:47 EDT
abrt-2.0.12-1.fc17, libreport-2.0.13-2.fc17, btparser-0.18-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.