Bug 826805 - KeyError: 'fstypeCombo'
KeyError: 'fstypeCombo'
Status: CLOSED DUPLICATE of bug 810141
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:d8bc61ce83f0addc4d1f322621c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 22:08 EDT by Joshua Roys
Modified: 2012-05-31 09:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 09:52:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-eAUW0c (466.47 KB, text/plain)
2012-05-30 22:08 EDT, Joshua Roys
no flags Details

  None (edit)
Description Joshua Roys 2012-05-30 22:08:16 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-eAUW0c
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Wed 30 May 2012 06:05:56 PM EDT
version:        17

anaconda-tb-eAUW0c: Text file, 477670 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 605, in editLogicalVolume
:    fmt_class = self.fsoptionsDict["fstypeCombo"].get_active_value()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 846, in editCurrentLogicalVolume
:    self.editLogicalVolume(lv)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 886, in editLogicalVolumeCB
:    self.editCurrentLogicalVolume()
:KeyError: 'fstypeCombo'

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.95FBya
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=America/New_York
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Joshua Roys 2012-05-30 22:08:25 EDT
Created attachment 587915 [details]
File: anaconda-tb-eAUW0c
Comment 2 Joshua Roys 2012-05-30 22:22:49 EDT
This prevents me from upgrading (easily) to F17 from F16.  x86_64 install DVD, selecting the clean install rather than upgrade option.  After selecting basic storage, I select custom layout & then attempt to assign the old mount points to partitions I don't plan on formatting.  This results in the traceback in this bug.
Comment 3 Joshua Roys 2012-05-31 09:52:37 EDT

*** This bug has been marked as a duplicate of bug 810141 ***

Note You need to log in before you can comment on or make changes to this bug.