Bug 826808 - Cannot install client tools on Fedora 17
Summary: Cannot install client tools on Fedora 17
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: ---
Assignee: Adam Miller
QA Contact: libra bugs
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-31 02:26 UTC by John Poelstra
Modified: 2015-05-15 01:56 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-06-22 22:27:57 UTC


Attachments (Terms of Use)

Description John Poelstra 2012-05-31 02:26:32 UTC
Description of problem:

Cannot install client tools on Fedora 17


rror: Package: rubygem-sshkey-1.3.0-1.el6_2.noarch (li)
           Requires: ruby(abi) = 1.8
           Installed: ruby-libs-1.9.3.194-10.1.fc17.x86_64 (@fedora)
               ruby(abi) = 1.9.1
           Available: ruby-libs-1.8.7.352-5.el6_2.x86_64 (li)
               ruby(abi) = 1.8
Error: Package: rubygem-net-ssh-2.3.0-1.el6_2.noarch (li)
           Requires: ruby(abi) = 1.8
           Installed: ruby-libs-1.9.3.194-10.1.fc17.x86_64 (@fedora)
               ruby(abi) = 1.9.1
           Available: ruby-libs-1.8.7.352-5.el6_2.x86_64 (li)
               ruby(abi) = 1.8
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Adam Miller 2012-05-31 21:40:18 UTC
We will need to find a location to host this RPM if this is in fact a desired approach but there is a new F17 compliant SPEC in a branch of os-client-tools called origin/f17

Comment 2 Harish Pillay 2012-06-13 06:45:14 UTC
Any further updates? 

I am going to run an intro to openshift talk on Saturday June 16 and would need to show it on a Fedora 17 machine.  Failing which, I might have to have a Fedora 16 VM on the Fedora 17 machine and show it from there.

Thanks.

Comment 3 Jeremy Eder 2012-06-13 12:42:34 UTC
Harish, this works on F17:

# yum install rubygem-rhc.noarch

It seems no openshift.repo was necessary for me.
rhc tool seems to work find after installing.

Comment 4 Guillermo Gómez 2012-06-13 15:03:54 UTC
For F17 installation bugs, please report it with rubygem-rhc component at Fedora instance (just found this by pure luck).

Meanwhile, there are new dependencies to get into account for version 0.93.18.

* rubygem-sshkey is not yet packaged

Dont use rubygem-rhc 0.93.18 from Fedora updates-testing 0.93.18 , dependencies are broken.

And yes there's no need on using openshift.repo in Fedora.

You should be ok using rubygem-rhc-0.92.11-1.fc17 from Fedora repos, just:

# yum install rubygem-rhc

Comment 5 Harish Pillay 2012-06-13 15:20:52 UTC
OK, Tried:

# yum install rubygem-rhc

and that works.  Perhaps I should disable the openshift repo.

Should I file a bz on the docs?

Comment 6 Abhishek D 2012-06-28 16:33:01 UTC
the docs should be updated


Note You need to log in before you can comment on or make changes to this bug.